Question Unknown Random Bluescreens/Crashes

Mar 22, 2022
14
2
15
0
For the past couple months or so, my pc has been randomly bluescreening with error codes that usually have to do with memory, but I've ran 10 or so passes of memtest for hours on end and it comes out perfectly clean. I'll just be watching youtube and tabs will randomly crash, and sometimes even Firefox as a whole will crash. It has to be a hardware issue, because I reset windows completely (wiped drive then fresh install media) and it still happens. I've bluescreened 5 times today already, and included the dump files if y'all wanna take a look at them. https://www.mediafire.com/file/9orivha50lqt45u/minidump_files.zip/file
 

gardenman

Distinguished
Moderator
Hi, I ran the dump files through the debugger and got the following information: https://jsfiddle.net/rnkb6Lzp/show This link is for anyone wanting to help. You do not have to view it. It is safe to "run the fiddle" as the page asks.
File information:032222-5375-01.dmp (Mar 22 2022 - 21:58:18)
Bugcheck:SYSTEM_SERVICE_EXCEPTION (3B)
Probably caused by:memory_corruption (Process running at time of crash: firefox.exe)
Uptime:0 Day(s), 5 Hour(s), 31 Min(s), and 24 Sec(s)

File information:032222-4968-01.dmp (Mar 22 2022 - 01:27:21)
Bugcheck:SYSTEM_SERVICE_EXCEPTION (3B)
Probably caused by:memory_corruption (Process running at time of crash: MSIAfterburner.exe)
Uptime:0 Day(s), 3 Hour(s), 57 Min(s), and 53 Sec(s)

File information:032222-4875-01.dmp (Mar 22 2022 - 07:42:24)
Bugcheck:KERNEL_SECURITY_CHECK_FAILURE (139)
Probably caused by:memory_corruption (Process running at time of crash: Discord.exe)
Uptime:0 Day(s), 3 Hour(s), 43 Min(s), and 46 Sec(s)

File information:032222-4828-01.dmp (Mar 22 2022 - 03:58:04)
Bugcheck:MEMORY_MANAGEMENT (1A)
Probably caused by:memory_corruption (Process running at time of crash: MoUsoCoreWorker.exe)
Uptime:0 Day(s), 2 Hour(s), 30 Min(s), and 16 Sec(s)

File information:032222-5062-02.dmp (Mar 22 2022 - 16:26:28)
Bugcheck:KERNEL_SECURITY_CHECK_FAILURE (139)
Probably caused by:memory_corruption (Process running at time of crash: firefox.exe)
Uptime:0 Day(s), 8 Hour(s), 43 Min(s), and 29 Sec(s)
Comment: The overclocking driver "RTCore64.sys" was found on your system. (MSI Afterburner)

Possible Motherboard page: https://www.asrock.com/mb/Intel/Z490M-ITXac/index.asp
You are using the latest available BIOS.

This information can be used by others to help you. Someone else will post with more information. Please wait for additional answers. Good luck.
 
Mar 22, 2022
14
2
15
0
Oh yeah, I forgot to include this. It can't have anything to do with my overclock because I tried turning both xmp and my cpu overclock off and it still does this. Just replying here incase someone else sees. Thanks for making the dumps easy to look at Gardenman. (for some reason I get an error when I try to reply to your comment)
 

gardenman

Distinguished
Moderator
Colif asked me to look at the dumps so he'll reply sometime over the next few hours if he's awake.

The issue could be a driver, or hardware. IObit has a bad reputation here and other places, so I would go ahead and remove the uninstaller while you wait for more answers.

I've seen Malwarebytes cause issues before. I would tell you to temporarily remove it, Colif probably will not. It's up to you, but the less things you have running in the background will make it easier and faster to get to the real issue.

Also, about the overclock: You can have multiple reasons for having multiple BSODs. Meaning that you can fix one (maybe a bad driver) and still be crashing because of an overclock or other issue. Just keep that in mind.

More answers will come later.
 
Mar 22, 2022
14
2
15
0
Colif asked me to look at the dumps so he'll reply sometime over the next few hours if he's awake.

The issue could be a driver, or hardware. IObit has a bad reputation here and other places, so I would go ahead and remove the uninstaller while you wait for more answers.

I've seen Malwarebytes cause issues before. I would tell you to temporarily remove it, Colif probably will not. It's up to you, but the less things you have running in the background will make it easier and faster to get to the real issue.

Also, about the overclock: You can have multiple reasons for having multiple BSODs. Meaning that you can fix one (maybe a bad driver) and still be crashing because of an overclock or other issue. Just keep that in mind.

More answers will come later.
Alright, I uninstalled Malwarebytes and updated every driver I could and it still does it. I also realized that sometimes programs will just hang for like 1/4 of a second too if that helps to figure it out
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
55,397
4,327
160,590
10,079
and then I forgot. sorry about that

2nd crash - GPU drivers. its pretty obvious, victim was afterburner and stack text of error mentions DirectX. Unless its Afterburner tripping over itself
Feb 09 2022nvlddmkm.sysNvidia Graphics Card driver http://www.nvidia.com/
I think there are newer ones now.

try running DDU in safe mode, remove drivers and reinstall again - https://forums.tomshardware.com/faq/how-to-perform-a-clean-install-of-your-video-card-drivers.2402269/
could try updating Afterburner but unlikely program crashes because of own drivers.

some of them could be lan drivers, given discord, Firefox and windows update are among victims (some of these could be GPU drivers as well)
I wonder which one you use
May 24 2019rt640x64.sysRealtek NICDRV 8169 PCIe GBE Family Controller driver https://www.realtek.com/en/

Sep 29 2020e1d68x64.sysIntel(R) Gigabit Adapter driver

Sep 03 2018Netwtw04.sysIntel Wireless Wifi Link driver https://downloadcenter.intel.com/

are you on WIFI or Ethernet, and if Ethernet, realtek or Intel? Too many choices :)

You could run the Asrock App shop and let it update drivers for your motherboard, there appear to be newer for all 3 LAN drivers - https://www.asrock.com/mb/Intel/Z490M-ITXac/index.asp#Download
 
Last edited:
Mar 22, 2022
14
2
15
0
and then I forgot. sorry about that

2nd crash - GPU drivers. its pretty obvious, victim was afterburner and stack text of error mentions DirectX. Unless its Afterburner tripping over itself
Feb 09 2022nvlddmkm.sysNvidia Graphics Card driver http://www.nvidia.com/
I think there are newer ones now.

try running DDU in safe mode, remove drivers and reinstall again - https://forums.tomshardware.com/faq/how-to-perform-a-clean-install-of-your-video-card-drivers.2402269/
could try updating Afterburner but unlikely program crashes because of own drivers.

some of them could be lan drivers, given discord, Firefox and windows update are among victims (some of these could be GPU drivers as well)
I wonder which one you use
May 24 2019rt640x64.sysRealtek NICDRV 8169 PCIe GBE Family Controller driver https://www.realtek.com/en/

Sep 29 2020e1d68x64.sysIntel(R) Gigabit Adapter driver

Sep 03 2018Netwtw04.sysIntel Wireless Wifi Link driver https://downloadcenter.intel.com/

are you on WIFI or Ethernet, and if Ethernet, realtek or Intel? Too many choices :)

You could run the Asrock App shop and let it update drivers for your motherboard, there appear to be newer for all 3 LAN drivers - https://www.asrock.com/mb/Intel/Z490M-ITXac/index.asp#Download
Alright, I went in safe mode and used DDU to uninstall the drivers, then I reinstalled them. I also updated all 3 internet drivers. (I'm using the Realtek ethernet btw) I'll let you know if I crash again, and if I do, I can always try using just my integrated graphics to see if it has to do with my gpu.

Maybe there's more wrong with my gpu...?? My gpu does this weird thing where the fans spin up and then stop over and over again, and doesn't stop until I go into MSI afterburner and turn the fan speed to 100, then back down to auto mode.

UPDATE: This tab crashed 3 seconds after posting this LMAO
UPDATE 2: My whole pc bluescreened less than a minute after posting that update
UPDATE 3: Still crashes after removing gpu, crashlog here: https://www.mediafire.com/file/ytw440pyffnhm32/032722-4953-01.dmp/file
 
Last edited:

Colif

Win 11 Master
Moderator
Jun 12, 2015
55,397
4,327
160,590
10,079
Maybe there's more wrong with my gpu...?? My gpu does this weird thing where the fans spin up and then stop over and over again, and doesn't stop until I go into MSI afterburner and turn the fan speed to 100, then back down to auto mode.
You might want to look at the Temperature Hysteresis value in Afterburner. You can set it so fans shouldn't turn on/off all day
It's the difference in temperature required before the curve ramps. In other words if the GPU is currently 55c and you set the hysteresis to 5, then the fans won't ramp to the next setting unless the temp moves 5c in one direction or the other. A setting of five or 10 degrees is recommended, and means the fan will allow the GPU to cool by this amount before switching to a different fan speed. This helps prevent fluctuating speeds as the temperature crosses the thresholds on the graph.
link

Update 3 tells us its not likely to be GPU.
 

gardenman

Distinguished
Moderator
I ran the dump file through the debugger and got the following information: https://jsfiddle.net/mc2khfyg/show This link is for anyone wanting to help. You do not have to view it. It is safe to "run the fiddle" as the page asks.

File information:032722-4953-01.dmp (Mar 27 2022 - 19:49:43)
Bugcheck:MEMORY_MANAGEMENT (1A)
Probably caused by:memory_corruption (Process running at time of crash: NVDi)
Uptime:0 Day(s), 2 Hour(s), 24 Min(s), and 46 Sec(s)

This information can be used by others to help you. Someone else will post with more information. Please wait for additional answers. Good luck.
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
55,397
4,327
160,590
10,079
Jan 10 2020nvvhci.sysNvidia Virtual USB Host Controller driver http://www.nvidia.com/

Aug 11 2020NvModuleTracker.sysNVIDIA Module Tracker driver

Sep 13 2021nvvad64v.sysNvidia Virtual Audio driver http://www.nvidia.com/
Your NVIDIA drivers.
Now its not likely to be obvious to you but there is one thing missing there...
this bit
Feb 09 2022nvlddmkm.sysNvidia Graphics Card driver http://www.nvidia.com/
the actual graphics driver isn't there?

The process the PC was trying to run is only showing 4 characters but NVDi would probably be Nvidia

I would run ddu again and maybe it will get it right this time?

You have intel display drivers installed, I assume you not running off the integrated GPU.
 
Mar 22, 2022
14
2
15
0
Jan 10 2020nvvhci.sysNvidia Virtual USB Host Controller driver http://www.nvidia.com/

Aug 11 2020NvModuleTracker.sysNVIDIA Module Tracker driver

Sep 13 2021nvvad64v.sysNvidia Virtual Audio driver http://www.nvidia.com/
Your NVIDIA drivers.
Now its not likely to be obvious to you but there is one thing missing there...
this bit
Feb 09 2022nvlddmkm.sysNvidia Graphics Card driver http://www.nvidia.com/
the actual graphics driver isn't there?

The process the PC was trying to run is only showing 4 characters but NVDi would probably be Nvidia

I would run ddu again and maybe it will get it right this time?

You have intel display drivers installed, I assume you not running off the integrated GPU.
I did that and also uninstalled every graphics driver using ddu (even amd, which I don't have) then reinstalled gpu drivers through GeForce Experience and it still crashes. I'm also getting weird issues now where all of my cookies on Firefox just get cleared so I have to sign into everything again

Here's some of the new dumps but I doubt its anything different
https://www.mediafire.com/file/22qpmvomwfde9re/Desktop.rar/file
 
Last edited:

Colif

Win 11 Master
Moderator
Jun 12, 2015
55,397
4,327
160,590
10,079
What are full specs of the PC?
CPU - Intel(R) Core(TM) i7-10700K
MB - Z490M-ITX/ac
Ram - 16gb G Skill -F4-3600C18-8GVK
what ssd/hdd do you have?
what else is in PC?

Windows counts Page file as memory, its on C drive.

I wonder if problem is the drives. could explain why things go missing, its odd you had most of Nvidia installed before but not the actual GPU driver itself.

Most drive makers have software you can use to test drives, if you tell me what you have I can find the tools.
 
Mar 22, 2022
14
2
15
0
What are full specs of the PC?
CPU - Intel(R) Core(TM) i7-10700K
MB - Z490M-ITX/ac
Ram - 16gb G Skill -F4-3600C18-8GVK
what ssd/hdd do you have?
what else is in PC?

Windows counts Page file as memory, its on C drive.

I wonder if problem is the drives. could explain why things go missing, its odd you had most of Nvidia installed before but not the actual GPU driver itself.

Most drive makers have software you can use to test drives, if you tell me what you have I can find the tools.
My C drive is a Adata XPG Gammix S5 512GB
My D drive is a Silicon Power A80 P34 512GB
and my E drive is a WDC WD10SPCX-60KHST0 1TB

The first 2 are NVMe's and the last one is a hard drive, if that makes a difference.
The only other thing in my PC is the EVGA RTX 3060 XC
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
55,397
4,327
160,590
10,079
run this on adata drive - https://m.majorgeeks.com/files/details/adata_ssd_toolbox.html
run this on silicon power drive - https://www.silicon-power.com/web/download-ToolBox
try running the tests in this on hdd - https://support.wdc.com/downloads.aspx?lang=en&p=279

they should at least be able to show SMART scores. SMART is auto reported so don't need to run any tests in software but the wdc has extra tests to check surface of drive.

The only other thing in my PC is the EVGA RTX 3060 XC
and a PSU :)
 

gardenman

Distinguished
Moderator
I ran the new dump files through the debugger and got the following information: https://jsfiddle.net/9yjm3xf4/show This link is for anyone wanting to help. You do not have to view it. It is safe to "run the fiddle" as the page asks.
File information:033022-5531-01.dmp (Mar 30 2022 - 10:54:39)
Bugcheck:MEMORY_MANAGEMENT (1A)
Probably caused by:memory_corruption (Process running at time of crash: MsMpEng.exe)
Uptime:0 Day(s), 7 Hour(s), 19 Min(s), and 56 Sec(s)

File information:033022-5500-01.dmp (Mar 30 2022 - 03:34:18)
Bugcheck:IRQL_NOT_LESS_OR_EQUAL (A)
Probably caused by:memory_corruption (Process running at time of crash: steam.exe)
Uptime:0 Day(s), 3 Hour(s), 39 Min(s), and 43 Sec(s)
This information can be used by others to help you. Someone else will post with more information. Please wait for additional answers. Good luck.
 
Mar 22, 2022
14
2
15
0
run this on adata drive - https://m.majorgeeks.com/files/details/adata_ssd_toolbox.html
run this on silicon power drive - https://www.silicon-power.com/web/download-ToolBox
try running the tests in this on hdd - https://support.wdc.com/downloads.aspx?lang=en&p=279

they should at least be able to show SMART scores. SMART is auto reported so don't need to run any tests in software but the wdc has extra tests to check surface of drive.


and a PSU :)
The SMART data for all of them was perfect, but I also ran the tests just to be sure. I do wanna note though, the SMART data for the XPG isn't working right because the power on count/hours are WAY lower than they should be. I installed both NVMe's close to the same time, and the Silicon Power's power on hours are more than 20x the hours of the Adata drive

The Silicon Power drive came out clean and so did the WD hard drive, but every time I tried to scan using the Adata tool but every test finished within like 4 seconds. Even the test that said it would take upwards of 8 hours finished within 5 seconds, so I doubt that's working right.

Also, I have a SeaSonic SGX-500 for a PSU
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
55,397
4,327
160,590
10,079
crash 1 victim = Defender
crash victim 2 = Steam

i see you have updated LAN drivers, still crashes...

both errors occurred in virtual memory.

I do wanna note though, the SMART data for the XPG isn't working right because the power on count/hours are WAY lower than they should be. I installed both NVMe's close to the same time, and the Silicon Power's power on hours are more than 20x the hours of the Adata drive
nvme can turn off when not in use, but there shouldn't be that big of a difference between two nvme like that
unless SP is where you have all your games and play them a lot, the difference between them is a little odd
I would question that Adata

The difference between my NVMe and my HDD makes sense:
both my drives installed same day
Samsung nvme shows 230 days, 22 hours
Western Digital hdd - 355 days, 14 hours

they both been "on" as long as each other.

could run this and see what it thinks of the drives. Can't run tests though on trial version - https://www.hdsentinel.com/hard_disk_sentinel_trial.php

have you ever installed win 10 on other nvme? I wonder if it would make any difference.
 
Mar 22, 2022
14
2
15
0
crash 1 victim = Defender
crash victim 2 = Steam

i see you have updated LAN drivers, still crashes...

both errors occurred in virtual memory.


nvme can turn off when not in use, but there shouldn't be that big of a difference between two nvme like that
unless SP is where you have all your games and play them a lot, the difference between them is a little odd
I would question that Adata

The difference between my NVMe and my HDD makes sense:
both my drives installed same day
Samsung nvme shows 230 days, 22 hours
Western Digital hdd - 355 days, 14 hours

they both been "on" as long as each other.

could run this and see what it thinks of the drives. Can't run tests though on trial version - https://www.hdsentinel.com/hard_disk_sentinel_trial.php

have you ever installed win 10 on other nvme? I wonder if it would make any difference.
I ran the program you said and it showed nothing, but I cloned my boot drive to my other NVMe, and so far I haven't had any crashes at all. I'll update you in a day or so if I get any bluescreens or have tabs crash

Edit: I spoke too soon. Firefox crashed already
 
Last edited:
Mar 22, 2022
14
2
15
0
crash 1 victim = Defender
crash victim 2 = Steam

i see you have updated LAN drivers, still crashes...

both errors occurred in virtual memory.


nvme can turn off when not in use, but there shouldn't be that big of a difference between two nvme like that
unless SP is where you have all your games and play them a lot, the difference between them is a little odd
I would question that Adata

The difference between my NVMe and my HDD makes sense:
both my drives installed same day
Samsung nvme shows 230 days, 22 hours
Western Digital hdd - 355 days, 14 hours

they both been "on" as long as each other.

could run this and see what it thinks of the drives. Can't run tests though on trial version - https://www.hdsentinel.com/hard_disk_sentinel_trial.php

have you ever installed win 10 on other nvme? I wonder if it would make any difference.
My motherboard is an open box one I bought for like $70 at Microcenter and it came with a bent pin in the socket, but I bent it back. I wonder if its the motherboard thats causing this. I have a friend who flips pcs so he has a spare LGA 1200 board I can borrow for a day or so to test that

edit: just got an error that could show that its the drive. Maybe the old drive corrupted some files and since I cloned the entire drive, it brought those corrupted files to the new drive, and thats why its still crashing.
See error here
 
Last edited:
Mar 22, 2022
14
2
15
0
try clean installing on the drive instead of a clone - its just a test anyway.

if it still throws lan errors at us on a clean install on a new drive, maybe it is the MB.
Sorry for taking a bit to respond, just wanted to thoroughly test if it would crash. I installed windows on an external SSD and have been using it for about 2 days straight now without it crashing (I couldn't step away from my computer for more than an hour without it crashing before). I got a crash at the start, but my PC froze at the "collecting data" part of the bluescreen so no dump data was collected, but I think that one was just a coincidence. Pretty sure that Adata drive may have been the issue. I'll update again if I get more crashes.

Thanks a ton for all your help. Thanks to gardenman too
Maybe now I can use my PC without going insane from the constant crashing lmao
 
Reactions: gardenman and Colif
Mar 22, 2022
14
2
15
0
looks like you need a new drive to replace the adata or just put the external drive in PC if you can... or just run as is. Your choice :)

Its your thread, you reply when you need to :)
I wonder if the Adata drive is fine, but the windows install just got corrupted somehow. I ran a scan of Macrorit Disk Scanner and also scanned the drive with HD Tune and both times it scanned clean. I may just try doing a clean install of windows on that and try it for a while, but also have a backup of my data just incase.
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
55,397
4,327
160,590
10,079
I do wanna note though, the SMART data for the XPG isn't working right because the power on count/hours are WAY lower than they should be. I installed both NVMe's close to the same time, and the Silicon Power's power on hours are more than 20x the hours of the Adata drive
this was what made me question the adata as SMART scores are reported by the drive, not the operating system.
But its your choice, if you have backups it shouldn't hurt.
 
Mar 22, 2022
14
2
15
0
this was what made me question the adata as SMART scores are reported by the drive, not the operating system.
But its your choice, if you have backups it shouldn't hurt.
Well, I guess its not my choice lmao. Every time I try to install windows, I get the error code 0x80300024 even after freshly putting the Windows installer on there using the media creation tool. I get it when trying to install to either of the NVMes. I even tried removing the adata ssd and I still get that error. Also, I booted into the external ssd's windows and now I've had Firefox crash twice just while trying to write this message
 

ASK THE COMMUNITY