Question Unknown USB device (Set Address failed) / (Device Descriptor Request Failed)

Nov 29, 2021
Hello guys! Sorry for my English, and I'm not a tech expert. I hope you can help me.

I made a mistake on backup my files. I'm using Seagate Backup Plus Slim USB 3.0 1TB portable drive. What I did was I tried to backup my files from external drives and archiving/compress them to the same drives using WinRAR to secure them with password (a dumb thing to do). While my first external drive is compressing (WD MyPassport USB 3.0 500GB), I tried to do the same to Seagate external drive so I can save more time. Suddenly, WinRAR appears a message "Not enough Disk Space", and forced to a halt on compression on both external drives. My WD drive is okay but my Seagate doesn't appear on 'This PC' anymore, thus the Set Address failed/Device Descriptor Request Failed is present when I checked on the Device Manager. Tried fixing whatever I do updates and troubleshooting, but none of them helps. My Seagate though is spinning and its LED light is working normally, hopefully there may be a chance to recover.

I shouldn't do any archiving/compressing inside external drives, especially when doing multiple tasks. Also, I shouldn't let my drives closed to each other on the same place. It's my fault and these will be a lesson to learn from my mistakes.

I searched the internet for solutions, but none worked. Tried plugging my Seagate external drive on my TV, it doesn't work while my WD runs perfectly. Tried to ask my siblings to test on their computers and laptops, but they didn't let me. Tried to plug in during BIOS, but the entire system freezes until I unplugged it. I don't want to bring my device to tech support shops because it costs more. Is there any way to fix this problem? Thank you in advance.

Here's my specs:
OS: Windows 10 Pro (x64)
Processor: Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz
Installed RAM: 8.00 GB
Motherboard: ASUS Prime B250M-A
HDD: 465GB Western Digital WDC WD5000AAKX-08ERMA0
GPU: 2047MB NVIDIA GeForce GTX 1060 6GB
PSU: Corsair CV650
Last edited: