Unplayable fps on csgo // Ryzen 1700, 1080ti

Jun 19, 2018
4
0
10
0
Specs: Ryzen 1700, 1080ti, MSI b350 pc mate motherboard, Samsung 850 evo ssd + SB 7200 rpm 1TB HD, 2x Corsair Vengeance 8gb ram 3200mhz and a 550watt Corsair PSU

My fps was completely fine on CSGO with a 1700/380 combo. I got a stable 350 fps with dips to the mid 250s which is exactly what I was getting with my I5 4460/r9 380 combo. I upgraded to the 1080ti and there were noticeable drops from 200fps to 120 which would piss me off, which ultimately led me to stop playing the game.

Fast forward several months later and I can't even scratch over 100 fps. Constant tearing and bad performance on a below average 40 fps on CSGO (128tick, offline match, 9 bots and myself on Dust 2)

To save any obvious questions, yes Multicore rendering is on. However it's only an extra 10 fps. I did manage to get 120 fps consistently when playing a couple of weeks ago however it kept dropping causing unplayable microstuttering.

I've tried:

- Removing and reinstalling all drivers (GPU specifically) but I suspect it's cpu related
- Flashing the bios/installing new motherboard driver
- Removing all overclocks but on stock settings the problem persists
- Adjusting performance settings in game and in the Nvidia control panel
- Changing Windows power options, however no matter what power options it yields the same performance
- Checked that Xbox DVR and Game Bar was disabled/removed
- Removed all potentially intefering background processes. Problem persists with CSGO being the sole thing running.
- Disconnected second monitor
- Used Nvidia Inspector "tweaks", none of which worked.
- I reinstalled windows (Last week) - the keep personal files option. No improvement, seems to have decreased fps dramatically.

Other games are fine fps wise. I get 90+ fps on ultra settings on Witcher and at least 144fps on ultra on Warframe. Multi tasking also yields no problems. I could have 50 tabs open and multiple videos playing in a browser while playing Warframe and there wouldn't be a noticeable fps drop...

I'm really not sure where else to look for the problem. Other people with similar/inferior setups (1700 with an inferior GPU) can get 300+fps in 128tick DM servers so its doubtful it's a ryzen problem specifically. It could be hardware/voltage related.

I can record some "gameplay" with hardware monitoring if necessary as in my frustration I may have overlooked something.

I would deeply appreciate any answers.

Edit1: Went to sleep, woke up and now my fps is hovering between 120-200 (On 128tick offline 10 players). It seems smooth enough to be playable but I'm still disappointed that I can't get a smooth 144hz playing experience. I am playing on the new Panorama beta for reference 1920x1080 all low settings. Still don't understand why I can't achieve 300fps stable, maybe I'll play around with ProcessLasso.

Edit2: Opened up the game again today after a new update. fps is now 90-120 with dips down that are noticeable. I should note that the sv/var is consistently yellow/red and spiking up and down. However this is always the case when the fps dips frequently.
 
Jun 19, 2018
4
0
10
0


Yes, several times. I even went through the process of making sure the cloud sync wasn't reinstalling a "broken" version of the game, but the result is still the same.

 

ASK THE COMMUNITY

TRENDING THREADS