Unsure why computer won't boot

Mar 31, 2018
3
0
10
Hello,
I recently got this old motherboard and cup got a few other parts for a good deal but can not seem to boot it. Was wondering if anyone has any tips or advice and or could tell me what CPU this is.

Start off with the problem when I push the power button both the CPU AND RA M LED COME on leading to no display have tried many things suggested on other forums starting to think that the mother board may be fried or at least hope that is the only problem.

The next problem I have is I'm not sure what cup this is as it's top label is no longer there will post pics in a sec or link to pics I know it's a i7 most likely 2end gen but may even be a bit off there.

LASTLY any advice on how to test or other solutions to my problem like maybe buying a new motherboard I tried the cpu on my other com but it won't fit in it's socket.

Parts for this computer
Motherboard ausus sabertooth can't find specific one (sabertooth x58)
CPU: i7 2nd gen unsure (i7 960)
Video card gtx760
Ram fury hyper ddr3
Power supply thermaltake
https://imgur.com/a/iESTl28 pic of the CPU and build
The best wire management ever
Alright now I figured out the parts thanks to another poster just need to figure out what is broken on this setup

I'm sorry for this info I seem to be more cmputer ileterate then I first thought
 

R_1

Judicious
Herald
cant tell anything from looking at the CPU pins other than what generation the CPU may belong to. we need a picture of the top of the heatspreader after it has been cleaned of thermal paste with alcohol and a lint free cloth. the model will be etched into the heatspreader.

the motherboard model number should be printed on the motherboard near the PCIe slots, you may need to remove the GPU to access it.
 
Mar 31, 2018
3
0
10


Hi thanks yes that did have the specs in that area now just need to figure out what is wrong with the thing T_T
 

ASK THE COMMUNITY

TRENDING THREADS