Question Unusual issue with my new RTX card

Apr 25, 2020
2
0
10
0
Hello, I recently bought an RTX 2070 Super FE, and before I continue, I should mention that I already spoke to Nvidia customer support almost immediately after receiving it since I had this issue the moment I bought the card, and they ended up shipping a replacement card. I was convinced the first time that it was a faulty card since the first card also seemed to be throttling itself or something (It couldn't reach FPS levels that it should easily be able to reach, even my old GPU was capable of running faster), but I got a replacement card and it is having the exact same issue as the original, but this time it doesn't seem to be throttling, so I'm not sure if it's faulty or not. Also, I don’t have this issue on my old EVGA GTX 1070, so I’m out of ideas for how to solve this.

My specs:
Intel i7-7700k
16 GB RAM
750-watt Corsair RM750 (Gold) power supply
Motherboard: ASRock B250M HDV
If any other specs need to be listed, let me know, I'll add them to this post.

As for my issue, I can't find anyone with my exact issue online, so I figured posting it somewhere was a good option. Basically, If I leave my PC off for a decent amount of time (maybe an hour or more) and boot it up, both of my monitors will say "No displayport signal" even though I can see my computer light up and all the fans are spinning. (If I press the power button while they say no signal, my PC shuts down almost instantly, rather than needing to hold in down, I figured this was important to include, since I don’t know if this is a sign that my PC isn’t booting properly) I can temporarily fix this issue by turning off my computer and starting it up again, and usually on the second boot it will start up properly. (I have had a few instances where it took 3 boots for it to work properly).
I tried going into the BIOS and seeing if a default setting was turned on again, but with no luck. I've also updated every driver known to man, and even updated my BIOS only for the issue to remain the same. I've tried everything that customer support said to do and what I could find online or try to do myself, including testing the PCI e slot and reinstalling the RTX 2070 Super to be sure. I can't tell if I have terrible luck with GPUs or this is because of an entirely separate issue. I know it only seems like a minor issue, but I don't want to risk running this card anyways just because it could be faulty and end up dying before I can get a refund or replacement. Please help me out with this if you can! Thank you!
 

ASK THE COMMUNITY