Question *Updated* Disk detected in Bios but not in Disk Manager

Status
Not open for further replies.

Umeed

Distinguished
Apr 16, 2013
168
1
18,715
5
Update

I reseated the Seagate Barracuda and the WD Black and now they're both detected in BIOS. I was able to initialise the WD Black in Disk Manager, but the Barracuda isn't showing up for some reason. The Barracuda was initialised prior to getting the WD Black, but i moved it over to the second SATA tray in my case.

I have the carbide air 540 and it has two HDD trays with built in SATA ports to connect the hard drives to and from there connect to the mobo and the psu. Tray 1 has the WD Black and its working great. Tray 2 has the Barracuda and I know the Barracuda works but for some reason isn't being detected in Disk Management but is in BIOS.

The build:
I7 4790k
z97x-ud3h (motherboard)
16gb ram
900w Antec (not modular cries in regret)
windows 10 professional

Storage:
1 - Crucial M550 ssd (main)
2 - WD Blue ssd
3 - Crucial MX500 ssd
4 - WD 2.5 hdd
5 - WD Black 6TB (not getting detected)
6 - Seagate Barracuda (was working now it is not being detected in Disk management)
7 - WD MyBook (external - USB 3.0)


tl;dr
Barracuda 1Tb drive is detected in BIOS but not Disk Manager, I do see it in Device Manager though. Not sure what to do from here.

View: https://imgur.com/YJG9Uuj
 
Last edited:

Umeed

Distinguished
Apr 16, 2013
168
1
18,715
5
okay so...I'm not sure what happened but after doing a couple refreshes and attempting to update the barracuda hdd driver in device manager which was unsuccessful since I had the latest drivers already it now shows up and is accessible lol

If a mod could close this thread, that'd be great thanks.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS