[SOLVED] Updated drivers on my motherboard. Now my m.2 ssd won't show up anywhere in Windows.

Aug 14, 2019
9
0
20
1
https://forums.tomshardware.com/threads/high-end-games-crash-suddenly-without-warning.3512676/#post-21226250

In attempting to get another issue resolved, I updated the drivers for my motherboard. Now my M.2 ssd won't show up in Disk Management or Device Manager. I can still see it in BIOS, but otherwise my computer has no idea it's there. I tried running Windows Memory Diagnostic like one Youtube video suggested, as well as the following fix:

Fix:
  • open Device Manager
  • expand IDE ATA/ATAPI controllers
  • right click on Standard SATA AHCI Controller, select Uninstall
  • reboot, after reboot drive shows up in Device Manager
Neither worked. Any help very much appreciated! My SSD is a Samsung PCle M.2 SSD 970 evo 500 gb. I can see it under NVMe configuration and boot override in BIOS. I do not have my OS installed on it, my OS is on another SSD. My motherboard is a Gigabyte B450 Aorus Elite. If you need more info let me know!
 
Last edited:
Aug 14, 2019
9
0
20
1
I haven't moved it. When I first installed it I apparently put in the wrong socket (the bottom one) and it didn't seem to work. I moved it into the first socket behind the GPU and then it worked. A motherboard update shouldn't have flipped it around, right?

I did try taking the SSD out and putting it back in the same slot, hoping for a miracle. No miracles occurred.
 

ASK THE COMMUNITY

TRENDING THREADS