Question Updated drivers to graphics card, black screen of death

Scot Frei

Honorable
Jun 18, 2014
6
0
10,510
0
My old computer died. I decided I might as well build a new one. COVID rolls up. Working from home. Daughter stuck at home. Need a second computer for e-learning. Rebuild my old computer with some replacement parts. Windows posts. Everything running fine.
Install drivers for video card. Black screen of death. There are no older drivers to roll back to. Clean install. The only way to get the computer to run is to disable the video card. I'd like to have it functional. I don't know where to find older drivers that play well with the system. I've installed all windows updates, at least according to windows. All components old. Windows 10 Home OS
Video card: R9 270
CPU: Intel i3-4130
Mobo:Gigabyte ga-h18m-hd2
Looking for next step.
Thank you for any direction.
 

Scot Frei

Honorable
Jun 18, 2014
6
0
10,510
0
I built a computer for my daughter to use while we weather this and do remote schooling. The computer is a frankenstein of old parts, but most of them were in use until a month or so ago and running fine. When I first tried to install drivers I got a black screen of death that could only be solved by disabling the GPU. Last night I tried with some older drivers and got a black screen during installation. I left it to run for ten or fifteen minutes before restarting.
Two questions:
1)Is a black screen during driver installation normal and should I allow longer than fifteen minutes to install? I don't remember it taking that long or creating a black screen.
2)Is there any way to isolate the problem? The mobo, PSU, and GPU are all more than five years old, but, as I said, running fine as of a month ago. I'd like to figure out which one has failed to trigger this problem.
Specs:

Video card: R9 270
CPU: Intel i3-4130
Mobo:Gigabyte ga-h18m-hd2
And I don't know what the power supply is, its bolted into its slot and the identifying marks are not apparent. The GPU powers up and the fans run, so its getting some power at least. And as of a month ago, the power supply was working with the GPU fine.
Thanks in advance for any suggestions.
-Mark
 

ASK THE COMMUNITY

TRENDING THREADS