Upgrade i5-650 Dual Core Cpu to i7 870 Quad Core, No video coming MSI H55M-E23

pinnaclesdr

Reputable
Jan 22, 2016
13
0
4,510
0
I have a Msi mother board H55M-E23 with the lastest bios from what the software was telling me. My pc right now has i5-650 dual core with 8 gb ram on a 240 ssd drive, and have win 10 pro.

This is the cpu:
Intel-Core-i7-870-2-93-GHz-Quad-Core-Processor-8-MB-Cache-Socket-LGA1156-CPU

So i got a cpu witch is i7-870 quad core and for some reason the pc starts but i don't get any video on screen , nothing "say no signal" , i have try other monitor still the same, i have try hdmi cable still nothing.

Can anyone give me some advice what i am doing wrong?

Thank you for any help!
 
You have a good point. I presumed the OP has a discrete GPU and the Intel graphics are not used, but that may be incorrect.

 

pinnaclesdr

Reputable
Jan 22, 2016
13
0
4,510
0
Not sure how to know if it has CPU with HD GFX...

The info at Msi site:

Socket 1156 CPU (Max Support) i3/i5/i7
Baseclock/Hyper Transport 6.4GT/s Chipset Intel® H55 DDR3
Memory DDR3 1066/1333/1600* (OC)
Memory Channel Dual DIMM Slots 2
Max Memory (GB) 8
PCI-Ex16 1
PCI-E Gen Gen2 (1x16)
PCI-Ex1 2
PCI 1
SATAII 6
TPM (header) 1 LAN 10/100/1000*1
USB 2.0 ports (Rear) 6
Audio ports (Rear) 3
VGA 1
HDMI 1
DVI 1
VGA Max Share Memory (MB) 512
DirectX DX10 Form Factor M-ATX APS Y

One of the mods at Msi forum said that the cpu should work with any bios , unless is defective.
 

pinnaclesdr

Reputable
Jan 22, 2016
13
0
4,510
0
Forgot to mention that i have reverted back to win 7 and still not working.

Also when i open the package up before install i notice 3 small spots of that cpu paste on it , on the part that connects with
the mother board, so after installing and did not work , that paste there is questionable...
 

pinnaclesdr

Reputable
Jan 22, 2016
13
0
4,510
0

Hello,

In the pci ports i have 2 usb cards (usb2 and a usb3), but no video card in the pci ports. I am connected directly to mother board in the vga port, i also try the hdmi too thats on the mb but still not working.

 

pinnaclesdr

Reputable
Jan 22, 2016
13
0
4,510
0

Any video card or?

May try to get one from Fry's Electronics, i guess a cheap one as i don't play games. Need to know what are the specs that should be ? or as long is a
pci-ex1 from what i see in specs.

Thank you!

 

pinnaclesdr

Reputable
Jan 22, 2016
13
0
4,510
0
Ok Thank you! Will go at open time in about few hours my time to frys to get one and will report back.

Thank you and appreciate your time and help friend!
 

pinnaclesdr

Reputable
Jan 22, 2016
13
0
4,510
0

Will that be from dos? or install the card with i5 cpu and then replace the i7?

 

pinnaclesdr

Reputable
Jan 22, 2016
13
0
4,510
0

Oh sorry, i meant to install / boot from cd, not Dos my bad.


 

pinnaclesdr

Reputable
Jan 22, 2016
13
0
4,510
0
Hello,

Update: I manage to get it fix. That video card did the trick and the video come on , and when to windows! The i7 cpu works great!

Thank you for helping! Appreciate a lot to all that wrote and give some advice.


Regards,
P.
 

Similar threads


ASK THE COMMUNITY