[SOLVED] Upgrade trouble

Jul 30, 2019
7
0
10
0
My brother upgraded his a320m to an x470 gaming 5 and nothing worked and someone told us that the cpu wasnt compatible and it wasnt so he upgraded to a 3600 but now only some things work but no video output, gpu makes heat like its on but no fans on gpu rx 580
 

boju

Champion
Have a look here and check you have power supply cables where they're meant to be.


Can you give more information plz, on specs and what components were tried.

X470 would need a bios update to run 3rd gen using a 1st/2nd gen Ryzen to do the update.
 
Reactions: PharaohJoe

boju

Champion
Have a look here and check you have power supply cables where they're meant to be.


Can you give more information plz, on specs and what components were tried.

X470 would need a bios update to run 3rd gen using a 1st/2nd gen Ryzen to do the update.
 
Reactions: PharaohJoe
Apr 1, 2019
31
4
35
2
Yes, check the pcie cables from the PSU to make sure they’re properly plugged into the RX 580. Also, make sure the RX 580 is in the first PCIE slot which is x16.

As boju mentioned, an X470 needs to have its bios updated to support the 3600 and the update can’t be done without a compatible cpu already installed. So you’d need to buy an older AM4 socket processor and use it to flash the bios then switch it out with the 3600 after
 
Last edited:
Jul 30, 2019
7
0
10
0
Have a look here and check you have power supply cables where they're meant to be.


Can you give more information plz, on specs and what components were tried.

X470 would need a bios update to run 3rd gen using a 1st/2nd gen Ryzen to do the update.
This may be the problem but dont have another compatile cpu so is there something else we can do?
 
Jul 30, 2019
7
0
10
0
Yes, check the pcie cables from the PSU to make sure they’re properly plugged into the RX 580. Also, make sure the RX 580 is in the first PCIE slot which is x16.

As boju mentioned, an X470 needs to have its bios updated to support the 3600 and the update can’t be done without a compatible cpu already installed. So you’d need to buy an older AM4 socket processor and use it to flash the bios then switch it out with the 3600 after
Thats such a stupid system lol but thank you i will gove it a try
 
Jul 30, 2019
7
0
10
0
Yes, check the pcie cables from the PSU to make sure they’re properly plugged into the RX 580. Also, make sure the RX 580 is in the first PCIE slot which is x16.

As boju mentioned, an X470 needs to have its bios updated to support the 3600 and the update can’t be done without a compatible cpu already installed. So you’d need to buy an older AM4 socket processor and use it to flash the bios then switch it out with the 3600 after
The 580 is in the 1st slot and power cables are fine. Would this be effected by not having the right bios?
 

boju

Champion
This may be the problem but dont have another compatile cpu so is there something else we can do?
Either consult amd for a processor loan - bit of mucking around and patience.
https://www.amd.com/en/support/kb/faq/pa-100

Possibly buy a cheap Athlon 200ge

Or take it to a PC store so they can update bios.

---

Does the x470 motherboard box say Ryzen 2000 ready? New models off the production line could have the bios applied, depends how old in stock your motherboard was situated.
 
Jul 30, 2019
7
0
10
0
Either consult amd for a processor loan - bit of mucking around and patience.
https://www.amd.com/en/support/kb/faq/pa-100

Possibly buy a cheap Athlon 200ge

Or take it to a PC store so they can update bios.

---

Does the x470 motherboard box say Ryzen 2000 ready? New models off the production line could have the bios applied, depends how old in stock your motherboard was situated.
We will try this thanks. Would this effect the gpu like it did or is there maybe another issue? We are very new to this
 

boju

Champion
The graphics card will use a bit of power but wont display anything until the cpu is running properly.

Regarding the fans not spinning that is called smart fan control. The fans will start spinning once reaching a certain temp of around 60c.
 
Last edited:
Jul 30, 2019
7
0
10
0
The graphics card will use a bit of power but wont display anything until the cpu is running properly.

Regarding the fans not spinning that is called smart fan control. The fans will start spinning once reaching a certain temp of around 60c.
Youre the best dude thanks alot will try some of this out today
 
Apr 1, 2019
31
4
35
2
The 580 is in the 1st slot and power cables are fine. Would this be effected by not having the right bios?
I just did some research and I believe your motherboard supports Q-Flash Plus, which allows you to flash the BIOS without an installed CPU.

Here are the instructions for using Q-Flash Plus from Gigabyte's manual:
  1. From GIGABYTE's website, download the latest compressed BIOS update file that matches your motherboard model.
  2. Uncompress the downloaded BIOS file, save it to your USB flash drive, and rename it to GIGABYTE.bin. Note: The USB flash drive must use the FAT32/16 file system and it must be a USB 2.0 flash drive.
  3. Insert the USB flash drive into the white USB port on the back panel.
If both the main and backup BIOS fail during system boot, wait for 15-20 seconds, the system will automatically search and match the BIOS file in the USB flash drive on the white USB port. The FBIOS_LED will flash when the BIOS matching and flashing activities start. Wait for 2-3 minutes and the FBIOS_LED will stop flashing when the main BIOS flashing is complete.

After the main BIOS is flashed, the system will reboot automatically and then DualBIOS™ will continue to update the backup BIOS. After completion, the system will reboot again and boot from the main BIOS for normal operation.
 
Last edited:

boju

Champion
Would be handy but not sure if q-flash plus is supported. I ran through the manual and only see the regular q-flash. I have a feeling q-flash plus is more to do with Intel boards, could be wrong.

Plz check for x470 gaming 5
 
Apr 1, 2019
31
4
35
2
Would be handy but not sure if q-flash plus is supported. I ran through the manual and only see the regular q-flash. I have a feeling q-flash plus is more to do with Intel boards, could be wrong.

Plz check for x470 gaming 5
Yes, Gigabyte X470 Aorus gaming 5 WiFi. It’s in the manual. There’s a section on Q-Flash Plus
 
Last edited:
Apr 1, 2019
31
4
35
2
Would be handy but not sure if q-flash plus is supported. I ran through the manual and only see the regular q-flash. I have a feeling q-flash plus is more to do with Intel boards, could be wrong.

Plz check for x470 gaming 5
Actually, you might be right. That document I linked is labeled “Unique Features”. There’s another download down the page for the User Manual, which doesn’t mention Q-Flash Plus. I don’t know why they list Q-Flash Plus in the Unique Features manual under the download section of the X470 gaming 5 if it doesn’t have Q-Flash Plus. I also glanced at the motherboard diagram and couldn’t find an FBIOS_LED light and there is no white USB port. It’s all very confusing
 
Last edited:
Reactions: boju

ASK THE COMMUNITY

TRENDING THREADS