Question Upgraded cpu and 2 hours later it stops working?

Mar 29, 2020
5
0
10
0
Current build:
Ryzen 3 2200g
RX 580 8GB
12 GB 2400 MHz
EVGA 500W bronze
msi B450M PRO-M2

Recently I bought a ryzen 5 3600 and upgraded my cpu. I upgraded my mobo to the newest bios for compatibility reasons.
Used static protection, cleaned the ryzen 3 and put it away, put the ryzen 5 in, put little thermal paste, put the fan on, booted it up and everything worked out fine.

Ran a benchmark program, budget cuts, no mans sky, and half life alyx. About 2 hours later i was watching youtube videos and doing math homework when my computer randomly shut off. Keep in mind that i have a backup battery and didn't get close to the cables. The computer then proceeded to enter an infinite loop of starting up, right up to the bios.
I then spent 4 hours troubleshooting. I first re-slotted my ram, gpu and mobo battery and i was introduced to a blank black screen. I then swapped my cpu and it worked fine. Swapped it again and i get black screen again.

Please help me if you can, i dont know what to do.




Update.
Ive tried downgrading the bios to the version when 3000 cpus were supported and i swapped back to the ryzen 5

First start up failed but second one succeeded, and i was logged in and at my desktop. After half a minute my pc shut down and restarted. After that i was in the loop again.
I managed to get into bios 3 times but it froze 3- 10 seconds in. Afterwards i am now stuck at a windows error saying im missing the file evbda.sys. i have taken out all usb plugs and my wifi card and now im at the blank black screen again.

Im thinking i might call canada computers to see if they can help, otherwise ill just return it.

Also the debug light was on cpu at some point but now its stuck on vga only
I tried reseating the ram and gpu but nothing worked.



Also worth noting,
When i had managed to access the desktop, task manager said that the ryzen 5 was running at 4.1 GHz. So maybe its self overclocking thus overheating or too little power for overclocked?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS