Question Upgraded CPU, GPU, RAM, and motherboard, but ended up with no display or USB power. I switched out my CPU with another, but still no dice

Aug 19, 2019
10
0
10
0
Edited to include PSU model

Hi guys. So the title says it all, but I'll provide some details. The new components are:

  • AMD Ryzen 5 2600
  • Gigabyte GA-AB350n motherboard
  • Corsair Vengeance DDR4-3000mhz RAM (2x8GB)
  • MSI Radeon RX 590
  • EVGA NEX650G
Post-purchase research told me that CPU compatibility might've been the problem, so I bought a cheap AMD A8-9600 that would for sure be compatible with whatever BIOS my motherboard had on it. After installing the new CPU, I still have the same symptoms: the rig turns on with the LED case lights, fans, and Mobo lights running, but there's no display or USB power.

I've tried it with and without the GPU; I've tried both CPU and GPU displays outputs (HDMI and DisplayPort for both); I've tried it with both sticks of RAM, one stick of RAM, one stick of RAM in a different slot, etc;

I have no idea what the problem could be. Neither CPU has any bent pins, the GPU is brand new, the motherboard was bought secondhand but had been used only once...the only thing I bought that said it "wasn't tested" was the RAM, and I can't see anything wrong with it.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS