Question Upgraded MOBO and CPU (Asrock b450m and Ryzen 5 2600X ), now computer won't POST (no video)

Mar 17, 2020
1
0
10
0
I'm copying+pasting the formatting from a similar post I made on reddit.

PCPartPicker Part List

Type​
Item​
Price​
CPU
$145.99 @ Amazon​
Motherboard
$64.98 @ Amazon​
Memory
$31.99 @ Adorama​
Storage
$59.99 @ Adorama​
Video Card
-​
Case
$80.48 @ Amazon​
Power Supply
-​
Prices include shipping, taxes, rebates, and discounts
Total
$398.43
Generated by PCPartPicker 2020-03-16 22:42 EDT-0400​

The motherboard above is an upgrade from the MSI b250m PRO-VD, and the CPU is an upgrade from the Intel Pentium g4560.

Describe your problem. List any error messages and symptoms. Be descriptive.

After replacing the MOBO and the CPU (and adding an additional 250GB SSD), I attempted to boot the computer. The LEDs are turning on, and the fans (including the CPU fan) are running. Also, the computer doesn't appear to be rebooting or crashing - it turns on, but then it just sits there and runs.

However, none of my peripherals seem to be getting recognized. My monitors get no signal (I've tried HDMI, DVI, and both together, all through the GPU). They automatically cycle through all available inputs, then switch to standby mode because they're not detecting anything. My keyboard and mouse aren't lighting up (caps lock light on the keyboard doesn't change, and mouse doesn't light up when moved or clicked). However, some USB devices (external hard drive and usb CD-rom drive) are lighting up and drawing power.

Because it's not sending any video output, I'm not sure if it's entering BIOS or not. Unfortunately, I also don't have a motherboard speaker (new MOBO didn't come with one), so I can't do any kind of diagnostic that way. I'm hoping to get one tomorrow, if any electronics shops are open.

List anything you've done in attempt to diagnose or fix the problem.

Reseated everything (CPU, GPU, RAM, SSDs, all connectors) multiple times.

Tried the RAM in both available slots.

Removed all USB peripherals.

Removed the CMOS battery for 5 minutes and held the power button down for 30 seconds with the PC unplugged.

Checked the CPU for bent pins or thermal paste (all good there).

Tried connecting multiple USB devices - they draw power, but keyboard isn't recognized (caps lock light doesn't change, for instance).

Most of the steps listed here. I didn't do breadboarding, because I don't have access to that, and I couldn't do the steps that involved the POST speaker, because I don't have that either. I also didn't mess with the PSU, because I don't trust myself to do that.

Post relevant photos of build/parts here.

Photo album of MOBO and connections.
Please ignore any dust, I'm going to take it out and air-dust it outside after it's up and running. Also, there are two photos with the ATX12v disconnected, that's just to show you what pins I'm working with. Every time I've tried to boot it, I've had the ATX12v connection plugged in.

Provide any additional details you wish below.

I have a few ideas as to what the problem might be, but I'm not an expert.

1 - My PSU has two 4-pin ATX12v connectors. My last MOBO had an 8-pin connector, and I believe I used both cables. This new MOBO only has one 4-pin connector, so I'm just using one of the two connectors. I've tried both of my PSU's connectors, and get the same result each time.

2 - I haven't reformatted the SSD that I previously had Windows installed on (I'm planning on formatting it and doing a clean install anyway). Could this be an issue?

3 - My PSU is only rated for 430w. PCPartpicker estimates my total draw at 245w, so I assume the PSU should be able to handle it, but could this be the issue?

Anyway, that's it. I'm stumped and frustrated. With my first build, everything just came together and worked, right out of the box, with minimal troubleshooting (aside from having to switch the boot order around). I'm fairly computer-savvy, but certainly not an expert, so I'm pretty much out of ideas at this point. I'm hoping somebody here will have an idea what I should try next.

Thanks for reading!
 

ASK THE COMMUNITY

TRENDING THREADS