Question Upgraded mobo, no display

okin

Distinguished
Dec 20, 2012
4
0
18,510
0
Spec’s
Old computer
Mobo Asus z97-pro
Cpu i5-4690k
Ram cosair vengeance 4gx2
Psu cosair hx850
GPUs EVGA gtx 770
HD western digital black 1t
SSD Samsung 870 evo 120g


Upgraded to

Cpu i7-8700k
mobo Asus prime z390-a
Cpu Asus GeForce rtx 2070
Ram GSkill tridentz 8gx2

Bought for testing

Mobo Asus rog strop z390-e
Ram cosair vengeance 8gx2 3000mhz

Okay peeps. I’m an amateur when it comes to building computers. As resourceful as I can be, I’m stumped. Over Black Friday I decided it was a good time to upgrade some of the main components of my desktop. Having windows 10, and reading to make sure I had my drives in order I went ahead and installed the new parts. I was defeated with only only power going to the motherboard.

I decided to build the computer out of the case to eliminate any chance of shorts. After this I was finally able to boot the mobo, and get some post leds(dram,cpu, boot, vga) to light up with the boot green/yellow light staying on.

The problem is I cannot get into bios with the hdmi or dvi display ports( only used a dvi-to-hdmi adapter) With only having the mobo, cpu, 8pin, 24pin, and 1 stick of ram I started to follow the guide to diagnosis motherboard displays here on tom’s. After running through everything, and not finding any direction to take, I decided to head to the store and buy a new mobo, and eventually ram to narrow down the reason to why I can’t get bios to boot.

After testing a different new i7-8700k cpu, a new motherboard, and new ram I am not able to really narrow down the reason to why I cannot get bios to display. I’ve even tried to hook up my gpu with all power adapters, and tried to display from that with failure. After getting the same results with 2 cpus, 2 mobos, and 2 sets of ram I decided to hook up my old mobo and compare. I noticed that the boot led on all mobos stayed green/yellow. Though when I used the hdmi port on the old mobo it didn’t work. I decided to try the vga port, and finally I got into one of my mobos bios.

Now I fell like I’ve narrowed it down to it being a display issue or some sort. My new gpu, and mobo do not have a vga port so I cannot test this theory. Only dvi and hdmi which both have failed. Which the dvi was an adapter to an hdmi cable.

Does anyone have any idea as to how to get my mobo to work? I’ve thrown $$$ into the mix, and time trying to figure that 2 sets of cpu,ram,mobo are just not working. I’ve treaded the internet for 2 days now looking for answers. Any computer gods out there able to lend this poor drunken soul some help?
 
Last edited:

Lutfij

Titan
Moderator
Out of curiosity, how old is your Corsair PSU? Are both ram kits DDR4-3000Mhz spec? Which slots did you drop the ram stick in? Have you tried removing the CMOS battery from the board for at least 30 minutes before replacing the battery and trying to fire the new system's up? With only the board, processor and rams (sans any storage device) you should be able to get to BIOS or at the very least see an error for no boot device found.

Also, did you inspect the CPU socket for bent or broken pins? What cooler are you working with for that processor?
 

okin

Distinguished
Dec 20, 2012
4
0
18,510
0
Cosair ram was 3000mhz
GSkill is 3200.

Cooler
Corsair Certified CWCH100 Hydro Series H100 CWCH100 Extreme Performance Liquid CPU

Psu
CORSAIR HX Series HX850 850W ATX12V 2.3 / EPS12V 2.91 SLI Ready CrossFire Ready 80 PLUS GOLD Certified Modular Active PFC Power Supply New 4th Gen CPU Certified Haswell Ready

All of the orginial
Parts were bought in the beginning of 2014, and have brought me this far! As cmos battery. I have taken them out for up to 10 minutes not up to 30. I’ve also tried to whole hard resetting. Taking battery out, unplugging all power, press power button for 30 sec, or short the power out. The first mobo I suspected maybe a pin could have been bent?? That’s what sent me to the store for a new rog mobo. Then I called
Asus and they lead me in the direction of faulty ram or dead board.
 

ASK THE COMMUNITY

TRENDING THREADS