Question Upgraded my PC, when I turned on the computer the keyboard, mouse, and monitor don’t work. Anyone know how to fix?

Feb 25, 2019
4
0
10
0
Hello, My name is lester and I just recently upgraded my computer. When I finished and completed setting everything up, I turned on the PC and I was so happy until I realized that it’s been 10 mins and my keyboard, mouse, and monitor aren’t turning on.
My pc specs are:
Ryzen 3 1300x (upgraded to Ryzen 5 2600)
Gtx 1050 2GB (upgraded to Rtx 2060)
8GB G.skill ram 2400 MHZ
500 W psu
2TB Seagate Baracuda
Please help I would very much appreciate it. Thank you. :)
 
What motherboard do you have? An a320, b350, or x370 board needs a bios update to upgrade to 2nd gen cpus. You may need to put the 1300x back in the mobo and perform a bios update to support the newer 2600.
You also could try a cmos reset. Of the above fails. I need to clear cmos every time i change hardware, even a stick of ram or the pc wont boot.
 
Feb 25, 2019
4
0
10
0
What motherboard do you have. An a320, b350, or x370 board needs a bios update to upgrade to 2nd gen cpus You may need to put the 1300x back in and perform a bios update to support the newer 2600.
You also could try a cmos reset.
I have the AB350 Gaming 3 from Gigabyte
I have the new bios update on USB and when performing the cmos reset do I have to completely remove the battery or just leave it there like halfway bc that’s what I did and waited for around 20 secs
 
Look in your manual for more detailed info on cmos reset. The basis for my b350 msi board is leave your pc shutdown with power supply connected and turned on. Look for 2 pins near the cmos battery labeled jbatt or simmilar. Bridge these 2 pins using a metal screwdriver for 10 seconds to clear cmos. Likely this wont help if you have an older bios tho.
You will need to install the old cpu to update the bios via usb, so if cmos doesnt help i would put the 1300x back in and flash the bios.
 
Feb 25, 2019
4
0
10
0
I have the AB350 Gaming 3 from Gigabyte
I have the new bios update on USB and when performing the cmos reset do I have to completely remove the battery or just leave it there like halfway bc that’s what I did and waited for around 20 secs
I installed a battery and it still not working also tried resetting the cmos and nothing’s working at all
 
Feb 25, 2019
4
0
10
0
Ok well you are going to have to update your bios.
If you have your 1300x, reinstall it and update the bios. You cannot update your bios with a 2600 installed.
Omg thank you! My computer is booting in now! While I had my old cpu installed I updated my nvidia drivers too so I’m all set. Thank you it was a big help :D
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS