Question Upgraded PSU,CPU,MB and I now lose signal when playing GPU intensive games...is my GTX 970 finally dead? or is it a RAM issue

crowruin

Distinguished
Feb 17, 2014
58
1
18,635
0
this issue happens when there is a lot of ruckus going on in Path of Exile where I get "No Signal" on my monitor and PC becomes unresponsive and I cant do anything with mouse/keyboard so Im forced to restart.

I can hear the ingame sound but then it just cuts off after a bit

Could it be a RAM issue or GPU issue?

I also play Overwatch and I can play it fine for hours no blank screen what so ever...I also tested Apex Legend runs fine too no blank screen.

I had this GPU for 5 years now so Im not sure if its the end of the road for it.

I also checked my Temps and they are fine no overheating on CPU/GPU I also don't Overclock

Im also under the impression that it could be the RAM because I ran CPU-Z and its not showing me my RAM Specs anymore same with Speccy.

I ran down to my local Microcenter and they also did some testing on the GPU and said that its in the GPU but I would like a 2nd opinion since it only does this on Path of Exile.

Please any help would be appreciated since this never happened on my old setup and yes I have reinstalled drivers for the GFX card 4 times now with DDU and tried old versions

I play on 1080p

Specs:
Ryzen 5 3600
GTX 970 Asus STRIX
16GB RAM Kingston Hyperx Fury 2133Mhz
MSI B450 Tomahawk MAX
NZXT C650 650W Gold+
1TB WD Blue HDD
2TB WD Black HDD
Samsung Evo Plus 500GB NVME SSD
 

kurdtnz

Commendable
Feb 24, 2020
1,011
156
1,490
39
Also, just a further point on your RAM, Ryzen's love fast RAM. Is your RAM a 2133Mhz kit or is it just what the speed it is currently running at?(i think 2133mhz is like a default speed.) If it is a faster kit, (like 3200mhz or 3600mhz) have you enabled XMP in the BIOS?
 

crowruin

Distinguished
Feb 17, 2014
58
1
18,635
0
Also, just a further point on your RAM, Ryzen's love fast RAM. Is your RAM a 2133Mhz kit or is it just what the speed it is currently running at?(i think 2133mhz is like a default speed.) If it is a faster kit, (like 3200mhz or 3600mhz) have you enabled XMP in the BIOS?
The RAM is a 2133Mhz kit and I have enabled XMP in bios but that only fixed the issue with POE for 1 day and half then it happened again. Because before enabling XMP it would happen a few minutes into playing POE....not doing anything intensive.
 

kanewolf

Titan
Moderator

crowruin

Distinguished
Feb 17, 2014
58
1
18,635
0
When you do that, disconnect all the drives except the M.2. That way there is no way the Windows installer will get "confused" or you won't accidentally wipe out your other drives.

Here is the sticky on doing a clean install -- https://www.tomshardware.com/news/how-to-do-clean-installation-windows-10,36160.html
I reinstalled windows and installed Path of Exile.

I did the encounter in the game that always caused the blank no signal screens and I didnt experience any issues so I think reinstalling Windows was the fix.
 
Reactions: kurdtnz

crowruin

Distinguished
Feb 17, 2014
58
1
18,635
0
When you do that, disconnect all the drives except the M.2. That way there is no way the Windows installer will get "confused" or you won't accidentally wipe out your other drives.

Here is the sticky on doing a clean install -- https://www.tomshardware.com/news/how-to-do-clean-installation-windows-10,36160.html
sadly it happened again and this time on Overwatch when it never happened before on this game :(

could it be the CPU temp?

or the RAM?

when Im playing Overwatch CPU/GPU temps are both 60c

EDIT: turns out when that happens its a BSOD caused by ntoskrnl.exe

there is also 2 Optional driver updates for the CPU in Windows Update

EDIT#2: I decided to buy RAM and see if that is the problem because Ive been reading a lot of posts with this similar issue and its usually a RAM problem

EDIT#3 Installed new RAM and it did the blank screen again so its 100% a gfx card issue sadly

Edit#4: it was indeed the GPU and its on the last legs so I bought a RX570 off a friend and have been playing for hours no problems
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS