Question Upgraded RAM after 3 years, new and identical RAM won't POST

Vedattt

Honorable
Sep 16, 2014
4
0
10,510
0
I built my system in 2017, a few days ago I bought identical RAM to what I had first bought. G.Skill DDR4 2400MHz 8Gx1 RAM, its code is F4-2400C15S-8GVR if it matters. And I bought this exact same RAM stick, the codes on both sticks match each other. The only thing that's different is that one was made in 2017, the other in 2020.

Motherboard: ASUS ROG Strix B250F GAMING
CPU: i5 7500

What I've tried so far:
I tried putting the sticks in an A2-B2 configuration as pointed by the mobo manual. I tried placing only the newly bought stick into the A2 slot, to see if the stick on its own would post. I tried updating BIOS.

With all of these tries, the result was the same: Old ram works perfectly fine on its own, new ram makes the system not post if it is connected in any way to the system. Additionally, the new ram makes the onboard LEDs show yellow/orange and occasionally red. The monitor doesn't even wake up so nothing's being sent there.

Googling only comes up with threads where people can't post for the first time, but my system works and boots perfectly fine, it's only this new IDENTICAL ram that is causing problems. No problems at all with CPU or anything of the sort.

Help please?

Edit: Tried clearing CMOS too. Looks like I'll just have to return the stick and try a new one...
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS