Question Upgraded RAM, PC boots but no screen black?

madrerik

Distinguished
Jun 25, 2013
85
0
18,640
1
Hello,
I’ve decided to upgrade the memory capacity for my PC and bought the Corsair Dominator Platinum 64GB 3600mhz (4x16gb) RAM. I installed all 4 sticks, but no video input was received. I removed two sticks and the computer booted alright. I interchanged the sticks for the other two sets and they also booted in a 2x16gb configuration. I checked the BIOS and enabled XMP to be able to reach the 3600mhz. Not sure why if I add the other two sticks I get no video input. All other BIOS settings were set to auto and the other memory! preset setting to disabled.

Additional details:

I have not flashed the BIOS ever since I bought in July 2020 (afraid of something going wrong).
I bought two kits with the exact same serial numbers, speeds and memory capacity.
Two sticks (32GB total) work with XMP enabled at 2933Mhz or less.
I tried manually setting the speeds to the lowest common speed, reinstalled RAMs and still was getting black screen.
I tested all four sticks independently and they all work, just not together.

PC specs:

i9-9900k 3.6Ghz
RTX 2080 ti
Corsair Dominator 32GB @ 2933Mhz (XMP enabled)
MSI z390 MEG ACE motherboard
850w PSU
 

madrerik

Distinguished
Jun 25, 2013
85
0
18,640
1
I would advise a bios update. May or may not fix your issue but it's a good start. Worried about losing power borrow or use a UPS backup for the update.

Not the first motherboard that I have seen that didn't want to post with 3600mhz ram when using 64gb total.
Is that basically the only danger to updating a BIOS, losing power? I have a UPS backup already - I could give it a try.
 

ASK THE COMMUNITY

TRENDING THREADS