Question upgraded to 3700X - now Win10 won't start

Oct 17, 2019
5
0
10
0
Hi guys,

My PC was:
Ryzen 1600
Corsair Vengeance 2x8GB 3000MHz
Gigabyte X470 Ultra Gaming (BIOS F42d)
Samsung 970EVO 500GB
SP 1TB SSD
Corsair RM750

Today I upgraded to 3700X + G.Skill TridentZ RGB 2x16GB 3200MHz

system boot goes fine (all 4 LED's check OK).
but then the system gets to the AORUS logo screen and loops in it (occasionally it also writes "preparing automatic repair" and loops in it).

it did boot once after a couple of times.... after a REALLY LONG TIME looping. but since then - nothing. doesn't boot anymore.

tried the Win10 flash boot media as repair tool - doesn't work.
tried to boot Ubuntu from USB - works fine.

any other options besides re-installing windows?
 

Wolfshadw

Titan
Moderator
did it step by step, version by version.
F30 -> F31 -> F40 -> F41 -> F42d
During those steps, did you make sure to install the other necessary updates?
Before update BIOS to F40, you have to install EC FW Update Tool (B19.0517.1 or later version) to avoid 4DIMM DDR compatibility on 3rd Gen AMD Ryzen™ CPU
F30 - Note : Update AMD Chipset Driver 18.50.16.01 or later version before update this BIOS
F5 - Note : Update AMD Chipset Driver 18.10.20.02 or latest version before update this BIOS.
-Wolf sends
 
Oct 17, 2019
5
0
10
0
During those steps, did you make sure to install the other necessary updates?






-Wolf sends
I'm 99% sure I did as instructed (it was ~2 weeks ago, so i'm not 100% sure).

it does identify the 3700X + RAM.
it DID boot into WIN10 once (after a long time).
it does boot into Ubuntu.
 
Oct 17, 2019
5
0
10
0
Ok so it's up. for now.....

few questions about a couple of settings in the BIOS:
  1. "other PCI device rom priority" - what should it be?
  2. "storage boot option control" - what should it be?
  3. in "fast boot" menu - what settings should I pick? (for the VGA for example - EFI or auto?)
 

ASK THE COMMUNITY

TRENDING THREADS