Question Uplay won't download Rainbow Six Siege

Aug 21, 2019
1
0
10
0
Siege won't download. It gets up to the point of being "ready to play" and then the downloading freezes.
It stays at the same MB/s rate but doesn't move or show that it's still downloading.
I've tried all the fixes I've seen online; running uplay as an admin, limiting my bandwidth, changing my compatibility.
I've tried about 8 times now. I've also completely uninstalled and erased Uplay and reinstalled it each time.

Every time it gets to the "ready to play" stage it ends up crashing my entire computer to the point where I have to hard reset the tower.

It can download other games just fine. I downloaded a demo version of uno (bc it was free) and I downloaded Prince of Persia: Sands of Time.
They both downloaded fine and went smoothly. I know they're much smaller files but I still can't figure out why siege won't download.

I have no idea what to do and it's really starting to frustrate me.

Any help would be greatly appreciated!
 

ASK THE COMMUNITY

TRENDING THREADS