urgent help DX11 error: CreateTexture failed: E_OUTOFMEMORY

Spoon1

Reputable
Mar 29, 2015
138
0
4,680
0
I just built a new computer when I join a Arma 3 multiplayer server I receive this error "CreateTexture failed: E_OUTOFMEMORY" sometimes even this one

"out of memory (request 3kb)
footprint1147666432 kb
pages 65536"

System
evga 500w
evga gtx 960 ssc
asrock b85m pro4
4x2 gb of ram
1tb hard drive
windows 7 32 bit

please help i have no clue what to do i'm completely stuck. PLEASE POST IN COMMENTS
 
Why you get the message is because the game is likely seeing two graphics cards in the system.
The error will relate to the fact that you have a motherboard with on board graphics as well as your evga gtx 960 ssc in the Pci-e slot of the board.

You have two options here, and in both cases you have to enter the bios of your motherboard.
Your first if you can is to see if you have the option to disable the on board graphics solution on the motherboard as said by the bios options. If the option does not exist.

You should set your primary display adapter in the bios to Peg, or Pci-e mode.
The reason for the error is because the game is looking at the on board graphics solution.
Where the amount of memory used for it and texture storage comes from your main system ram of 8Gb.
The value set in the bios to reserve system ram for on board video ram can be extended or reduced in a menu, or option of the bios.
You best option is to disable the on board graphics solution, or make sure both the on board and evga gtx 960 ssc are not set to run together at the same time in your bios.

Once you have made the changes in the bios, don`t for get to save them before you exit the bios.
After that the game should run fine without the error message popping up when running Arma 3.
 
Why you get the message is because the game is likely seeing two graphics cards in the system.
The error will relate to the fact that you have a motherboard with on board graphics as well as your evga gtx 960 ssc in the Pci-e slot of the board.

You have two options here, and in both cases you have to enter the bios of your motherboard.
Your first if you can is to see if you have the option to disable the on board graphics solution on the motherboard as said by the bios options. If the option does not exist.

You should set your primary display adapter in the bios to Peg, or Pci-e mode.
The reason for the error is because the game is looking at the on board graphics solution.
Where the amount of memory used for it and texture storage comes from your main system ram of 8Gb.
The value set in the bios to reserve system ram for on board video ram can be extended or reduced in a menu, or option of the bios.
You best option is to disable the on board graphics solution, or make sure both the on board and evga gtx 960 ssc are not set to run together at the same time in your bios.

Once you have made the changes in the bios, don`t for get to save them before you exit the bios.
After that the game should run fine without the error message popping up when running Arma 3.
 
This is so technical, I am going to have to ask you to go to Arma or Steam, and deal with them. They know what the problems are with their software. I just went through looking at what Google has, and there are quite a few of those errors out there, and without me mentioning Arma, lots of them were Arma. Unfortunately, the closest I saw that they thought answered the why part was that there was a programming call (Release()) which was responsible since release() does not release memory immediately. But even that might not have been the entire story, and again, Arma and/or Steam would be a better place to try and resolve this.
 

Spoon1

Reputable
Mar 29, 2015
138
0
4,680
0


I found the thing but which one do I choose??? PCI express or PCI
 

Spoon1

Reputable
Mar 29, 2015
138
0
4,680
0


I found out but it was already set to PCI express. I'm still confused on what your second solution was
 

Spoon1

Reputable
Mar 29, 2015
138
0
4,680
0




This is my error now
"out of memory (request 0kb)
footprint1171521536 kb
pages 65536" when I load into a server it says that
 

Spoon1

Reputable
Mar 29, 2015
138
0
4,680
0


I've done everything you've said... Any other options ?
 

ASK THE COMMUNITY

TRENDING THREADS