Question USB 2 devices not working on USB 3.0 ports

Dec 13, 2022
Hello, I have an Asus rog laptop
Unfortunately, everything was working fine until the USB 3.0 ports stopped seeing 2.0 devices (I tried several: a mouse, a soundcard, an iPhone, USB flash drive...). USB 3.0 devices (for example an external hdd) are working normally on every port.
All the devices I tried were working fine before this failure, and they still work on the USB 2.0 port.
I tried to update and reinstall the usb drivers, I tried older versions, updating device drivers, but nothing worked.

I have updated the drives.
I have updated the BIOS.
I have removed and reinstalled the USB drives
But USB 3 still works easily, but USB 2 hardware doesn't work like a mouse
USB2 flash drives


Welcome to the forums, newcomer!

Asus rog laptop
Model for your Asus ROG laptop?

Have you tried reinstalling the chipset drivers for your laptop, with the latest source off f Intel/AMD? I'm assuming either of them since AMD's drivers will need to be sourced from AMD's support site while Intel's drivers can be sourced from Intel's support site.

What OS are you working with?

I notice a "gl502" mentioned in the tags to this thread. There's a 2 letter SKU to differentiate the variant of the GL502 in your possession.