USB 2 malfunction with A8NE Nforce4 MB with > 2GB RAM


Aug 11, 2002
Hi Fellow TH readers,

I have the following problem:
When installing 3GB RAM under Vista in an A8N-E, the Microsoft Enhanced USB 2 Controller driver cant handle it, and subsequently marks some USB devices as malfunctioning and refuses to use them.

This is solvable by disabling USB 2.0 in the bios (or by disabling the Enhanced USB 2 Controller driver) and voila all USB devices are detected and work (albeit under USB 1.1)

Apparently this also solvable by reverting to 2GB RAM (as the driver bug is not caused until you have more than 2GB) But I really want the RAM in!

Does anyone know of another driver I can possibly use to fix this bug?

I have trawled the internet and found one particularly helpful source

... in it suggests that Microsoft Hotfix Kb925528 should fix the problem (but it doesnt)

... in the nvidia document some people report success, but I dont seem to meet with the same.

Perhaps another generic driver or even some XP driver of some description will help?? (Not sure about the compatibility between USB XP Drivers and Vista ones...)

My System:
1. MB: Asus A8N-E (nforce 4 ultra)
2. CPU: AMD Athlon 64 X2 3800+ (OC 2.33Ghz stock air/stock voltage)
3. MEMORY: Dual Channel: 2x1GB TWINX-3200C2 Corsair, 2x512MB TWINX-3200C2 Corsair (TOTAL 3GB), 380Mhz Clock
4. VIDEO: Leadtek 7800GT 256 MB (Only slightly OC'd)
5. HARD DISKS: 2xSeagate Barracuda 320GB SATA 1.5Gb Nforce 4 RAID 1, 1 x Western Digital 120GB PATA
6. DVD/CD: Pioneer 16x DVD-RW, LG 16x DVD-ROM
7. CASE: Thermaltake 430W Soprano

My USB Devices:
1: PRINTER: Canon Pixma ip4200 - works most of the time with USB 2 enabled
2: JOYSTICK: Logitech Extreme 3D PRO - works with USB 2 enabled
3: EXTERNAL HD: Cooler Master XCraft with 400GB SATA 2 Seagate Barracuda - does not work with USB 2 enabled
4: FLASH DRIVE: Super USB Drive - does not work with USB 2 enabled

Mouse and Keyboard are both PS2 devices.

Thank you for reading :)


Aug 11, 2002
Hi everyone,

This problem has been solved. Looks like Vista Update did not properly install update kb 925528 from Microsoft.

I had to do the following:
1. Manually download the kb file from micorosoft
2. Backup all usb*.* files from Windows\System32\drivers\
3. Expand all files from the above kb file using the expand command in Vista
3. Use Winrar to extract all files from what should be apparent as the driver cab file that the expand command extracts from the kb update file
4. Give users full permissions to usb*.* in Vista's Windows\System32\drivers\
5. Reboot into Windows XP on another partition
6. Copy all usb*.* files from the fourth folder that was extracted in part 3. (and also the dll file which I beleive is not needed)... this folder appeared to have the latest versions of the needed usb files
7. Reboot into Vista and pray... voila my devices all got redetected and worked!

Hope this helps someone - Enjoy!