Question USB 3.0 cards not working in PCIe slots

cburdick1

Distinguished
Jul 7, 2013
12
1
18,515
0
Hi Everyone,

Please excuse my lack of computer knowledge, I'm in unfamiliar water here. I built my most recent PC back at the beginning of 2019:

Windows 10 Home x64
MB: ASRock AB350M PRO4
CPU: AMD Ryzen 7 1700
PS: Corsair TX 650
Video Card: GIGABYTE GeForce GTX 1050 Ti
Memory: HyperX Fury 32GB (2 x 16GB) DDR4 2400MHz DRAM

I'm in dire need of some more USB slots, so I purchased a Rosewill USB 3.0 PCIE card (https://www.newegg.com/p/pl?d=Rosewill+RC-508+USB). Powered off, switched off PS, unplugged, installed it in the top PCIE (x1) slot and ran power to it from one of the cables coming from my power supply.

Started up the PC, plugged in my phone (which started charging) and waited for my phone to show up on my PC..... but it doesn't show up. Head over to the Device Manager, look under USB Controllers and there it is, with the little yellow triangle and exclamation point. Open it up and device status says "Device cannot start (Code 10)" After some Googling, I tried the following:

-Downloaded and updated drivers from Rosewill
- Right click Disable then Right Click Enable
-Right click and "Uninstall" and restart
-Turn off the PC, remove the card, re-start, shut down, reinstall and restart
- Move to lower PCIE slot and I get the same "Device cannot start (Code 10)"

I think: Maybe it's the card? So, I bought another USB 3.0 PCIE card(https://www.newegg.com/p/2BH-00HP-00005?Item=9SIAMD6ANP1026&utm_medium=TraEmail&utm_source=TEMC-New-Order-Confirmation-USA&cm_mmc=TEMC-New-Order-Confirmation-USA-_-9SIAMD6ANP1026)

Installed it and dammit, same problem. Plugged in my phone and it starts charging, so it's getting power. Updated it's drivers using the included CD, no dice.

Now I have both cards installed, and they both show up in Device Manager, but they both get the same error ("Device cannot start (Code 10)" ).

What next? My BIOS is old, like from when I built my pc, so maybe update it? None of the updates on the ASRock website appear to address PCIE slots, but perhaps its best to get it up to the most recent version?

I'm annoyed, so I'm giving up for now. Hopefully someone has a suggestion. I'm going to go have a beer and watch soccer for a bit... before I beat my PC with a hammer.
 

Ds_Tech

Great
Jan 25, 2021
134
13
95
2
Try connecting other usb devices pendrive, mouse keyboard if they work. It may be some driver issue search for drivers as per chipset on it.
Clear bios defaults. Remove cmos battery and install again.
 

ASK THE COMMUNITY

TRENDING THREADS