[SOLVED] USB 3.0 header weirdness ?

Feb 24, 2022
3
0
10
0
I have a prebuilt system that I have recently got a new case for to be able to get better cooling. The issue I have is that my USB 3.0 header does not work with my new case oddly. My old front IO still works if I hook it up to the motherboard but the new front IO will not work. I RMA'd the front IO ports since it is a new case. The replacement front IO came in and the same issue occurs. I was curious and took the replacement front IO to my brothers house and tried it on his PC. The replacement front IO works perfectly in his computer (also a prebuilt but slightly newer). Being that the replacement front IO that came in works perfectly in my brothers PC and the old front IO works from my old case. I have no idea why it the new front IO does not work. the old front IO is labeled as USB 3.0 on the cable itself. the only difference is my new connector is all black but my old connector has a blue end on it. everything else seems identical.
 

Satan-IR

Distinguished
Ambassador
Yeah HP makes like that. Usually, you can't even change the PSU because it doesn't use standard ATX header/connectors. Let alone making a proprietary USB 3 header work.
is there a way to get this header to work?
If you have pinout schematics as what pin is what and fashion your own harness and healder and do it like a spaghetti maybe. Is it impossible? No. Is it worth the hassle? Also no. I wouldn't go down that road as it were.
 
Reactions: Dima7king7

Satan-IR

Distinguished
Ambassador
Yeah HP makes like that. Usually, you can't even change the PSU because it doesn't use standard ATX header/connectors. Let alone making a proprietary USB 3 header work.
is there a way to get this header to work?
If you have pinout schematics as what pin is what and fashion your own harness and healder and do it like a spaghetti maybe. Is it impossible? No. Is it worth the hassle? Also no. I wouldn't go down that road as it were.
 
Reactions: Dima7king7

ASK THE COMMUNITY