Question USB 3.0 Just will not be detected as 3.0 but rather 2.1


Sep 22, 2020
I just got my Quest 2, about 2 weeks ago, for like a week straight, my link cable worked completely fine and it was giving me around 2.5gbps when testing the speed, every single time, but one random time, I plugged in my link cable and on the Oculus app it says that I am using usb 2.0, I check on USB Device tree viewer, and it now says this. I only have 2 USB 3.1 ports on my pc and when plugging into both, it says that my companion port is either 19 or 20, and it says "Companion Port 1-20 supports SuperSpeed), I am not able to test with any other computers or any other cables as I don't really have the money for either, I am led to believe that it has to do with the one time I used airlink, when I tried using cable afterwards that's when I ran into this problem. When I launch my computer, my host controller is "Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)", I once tried installing a different driver for it (USB xHCI Compliant Host Controller), and for the first time it worked, right until I unplugged my Quest 2, now when I do it, it does nothing.

My USB Device tree viewer report:

I have tried practically everything, I have tried enabling and disabling legacy USB support and XHCI hand off in bios, tried pushing the USB cable in really hard, tried 2 usb 3.1 ports, tried turning on my computer whilst the link cable is plugged, I have tried disabling "Allow the computer to turn off this device to save power", reinstalled Oculus app, factory reset my headset, reinstalled the Oculus Quest 2 drivers and more that I just cannot think off

I am yet to try booting a new OS of both a new Windows installation and Ubuntu and if that doesn't work then flashing a newer BIOS driver, to atleast diagnose the problem, I just can't find my flash drive

Motherboard: MSI H310M PRO-VDH PLUS
Operating System: Windows 10 Pro x64 (22H2 19045.2486)