Question USB 3.0 port only working on one device while USB 2.0 and USB-C ports do nothing but power devices

Jul 20, 2021
1
0
10
0
So, sometime after buying my ASUS Vivobook X541UAK I noticed that one of my ports stopped working. Before this, I was able to charge my iPhone, connect peripherals, etc... But now windows would briefly sound the device connected sound, then display an error notification saying, "USB device not recognized". In the device manager, it would list the connected device as Unknown USB Device. Uninstalling it and restarting came up with nothing. After this I began using my USB-C port with USB-hub attached and for a brief while it worked until it started displaying the error message again. Windows recognizes the USB hub connected to the c-port but not the devices connected to the hub. Flash forward two years and two complete resets and the same thing happens except now, only my USB 3.0 port works slightly and my USB 2.0 port is completely unresponsive. Only my Astrum MG300 works on the USB 3.0 port and nothing else.

TLDR: USB 3.0 port only works on my Astrum MG300 mouse and not any other device. Other than that, my USB-C and USB 2.0 ports only power devices but they are unresponsive.

Solutions I've tried: Resetting Windows, Selective suspend method, uninstalling and reinstalling the usb drivers in device manager and I need help fixing the issue

Here's a screencap of my device manager when Astrum MG300 mouse is connected to the USB 2.0 port
View: https://imgur.com/IpdCxDW


When the same mouse is connected to the USB 3.0 Port
View: https://imgur.com/a/eCJCO9M


I've noticed on my sister's laptop that there is a generic USB hub present in her device manager but not mine so I was wondering if that had anything to do with it.
 

ASK THE COMMUNITY

TRENDING THREADS