[SOLVED] USB 3 front panel completely freezes motherboard

Jan 3, 2021
3
0
20
1
Motherboard: MSi B450 Tomahawk Max
CPU: AMD Ryzen 5 3600
Case: Cougar MX330-X

Whenever I plug something into the USB 3.0 port on the front panel, the entire computer freezes, including the boot screen and the BIOS configuration screen. When it is plugged in on boot, the motherboard gets stuck on the VGA debug light and only an underscore appears on the screen. (The CPU light also lights up momentarily, in case that's important). But when I unplug it, everything unfreezes. So if I press the power button, the computer turns off once I unplug the USB 3 device. The back ports don't have this issue.

Things I have tried:
  • Updating the BIOS
  • Using only one stick of each RAM
  • Swapping the video card
I'm not sure whether it is the motherboard, the case, or the CPU at fault. Is anyone else having this problem, and is there a solution?
 
Jan 3, 2021
3
0
20
1
After running some tests with a cheap USB 3 motherboard connection to USB A adapter from Amazon, it turns out the case front panel is faulty.
 
Jan 3, 2021
3
0
20
1
Update: I booted up Windows on a flash drive, and a bunch of random lines show up before/during the boot screen. I don't think this is supposed to happen, so it may or may not be related to this issue.

Update 2: Apparently it doesn't freeze with my USB 3 flash drive (but it won't boot from that drive), and it freezes with USB 2 devices.

Update 3: When I have Debian loaded, rather than freezing, every device I connect to it turns on and off repeatedly. I get the message (usb 1-3: device not accepting address 86, error -71)
 
Last edited:
Jan 3, 2021
3
0
20
1
After running some tests with a cheap USB 3 motherboard connection to USB A adapter from Amazon, it turns out the case front panel is faulty.
 

ASK THE COMMUNITY