[SOLVED] USB boot with CSM disabled on Gigabyte X570 board

vanzi

Honorable
Jul 26, 2013
9
0
10,520
1
Motherboard: Gigabyte X570 Aorus Ultra
Processor: AMD Ryzen™ 7 3800X

I just can't get this motherboard to boot from a USB stick without the CSM support mode.

I'm using is the original Microsoft stick from the Window 10 box. It's been tested on my previous PC and where it boots fine without CSM support. It's FAT32 obviously.

In the new build, once I disable CSM support, the USB disappears from the boot options. It's still detected as I can see it in the USB configuration section, but no way to boot from it. Tried different ports, USB 2.0/3.0/3.1, front panel, back panel, no difference.

Secure boot is disabled, Fast boot is disabled, everything else is pretty much what was configured out of the box. I've even tried flashing to the most recent BIOS (version F11).

I went through a lot of threads but they all suggest a problem with the stick itself (which seems extremely unlikely here) or one of the 2 options (Secure/Fast boot) being enabled, which did not help in anyway. I've run out of ideas at this point.

I could put my old PC back together and use its MSI mobo to install Windows without CSM and then put the drive back, but I refuse to believe that a $300 mobo can't deal with it...
 
Last edited by a moderator:

vanzi

Honorable
Jul 26, 2013
9
0
10,520
1
Turns out it was corrupted USB stick after all... It seemed fine as all the files are still there, but it would just not boot no matter what without CSM.

Created a new USB stick with Windows 10 Media Creation Tool (also FAT32 by the way) and it was detected immediately.
 

Lutfij

Titan
Moderator
I'm wondering why you would have a Windows 10 installer disk that's in FAT32 format. Even if you use Windows Media Creation Tools to fabricate your installer(sans the licence key) you'll see that the drive is formatted in NTFS file format. Your first issue is that the drive you have is FAT32 which will require CSM.

If you have an NTFS formatted bootable installer, you will need to change the boot options to UEFI. Also, make sure you're on the latest BIOS update for your motherboard. Check to see if you have anything after F11, sometimes a latter BIOS update pops up even though you might think you're on the latest.

This is a family friendly site.
Watch your language!
Moderator
Lutfij
 

vanzi

Honorable
Jul 26, 2013
9
0
10,520
1
Just to clarify, I did not create the stick myself, it's the original Microsoft stick from the Windows 10 box version.

It also boots fine on the other motherboard without CSM. In fact this is the first time I hear that FAT32 would cause problems in UEFI boot (non-CSM).

I guess I can try creating an NTFS stick since I'm out of options anyway.
 

vanzi

Honorable
Jul 26, 2013
9
0
10,520
1
Turns out it was corrupted USB stick after all... It seemed fine as all the files are still there, but it would just not boot no matter what without CSM.

Created a new USB stick with Windows 10 Media Creation Tool (also FAT32 by the way) and it was detected immediately.
 

ASK THE COMMUNITY

TRENDING THREADS