Question USB-C disconnects / turns off ?

agonyoftechnology

Reputable
Jan 13, 2018
2
0
4,510
0
Hello
When I remotely control my digital camera via usb-c cable, the usb port will disconnect after a few seconds. I have to physically disconnect the usb cable and reinsert it to fix the error.
A few seconds after I restarted the software the error occurs again.



So far I tried:
Bios update to Version 3801 (there is an issue regarding the ryzen series and usb conectivity: AMD Finds a Fix for Ryzen's USB Problems, BIOS Patch Coming in Early April)
disable selective USB suspend ( like that )
update usb driver
uninstall and reinstall USB driver
Change power management settings for USB Root Hubs
turn off/in fast startup
disable/enable standby power in bios (like that)
disable/enable XHCI hand-off (like that)

none of the above methods changed the error in the slightest way.

I tested various cables, too:
USB-C to USB-C = error (tested two different cables)
USB adapter + USB-C to USB-C = error
USB to USB-C = no error

The error is probably related to my system or some components of it, because same cable with a macbook pro and a surfacebook = no error

so I guess the error is somehow related to the usb-c to usb-c cable type in relation to some pc components. any ideas?

---------------------------------------------------------
My System:
CPU: AMD Ryzen 9 3900x
GPU: Asus R9 280
MB: ROG STRIX X570-I Gaming
RAM: 32GB
PSU: Thermal Take Berlin 630W
SSD: Samsung 970 evo / 840 evo / 860 evo /crucial CT256
WIN: 10.0.19041

Peripheral:
sony a7III
tether tools cable

Software:
Sony Imaging Edge Desktop
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS