Question USB Controller does not have enough resources

Sep 20, 2019
2
0
10
0
Recently switched to a RYZEN system, using a RYZEN 5 3600X and an MSI X570 MPG Gaming Wi-Fi. Shortly after that I swapped cases, from a Silverstone RL06 to an NZXT H700. Shortly after swapping cases, I started encountering an issue with my USB ports. For some reason, certain devices don't work. Specifically, my Samsung BAR 32GB flash drive, my Xbox One Wireless Receiver and my Xbox 360 Wireless Receiver don't work at all, no matter what port I plug them into, but it's just those three things as far as I can tell. My mouse and keyboard work just fine in all the ports, as well as my two DAC's. A few days after getting this problem, an error message came up saying that the "USB Controller does not have enough resources". It comes up very inconsistently and sporadically, despite what I have plugged into my computer not changing very often. I tried reinstalling the USB drivers, reinstalling Windows via Fresh Start, tried all my currently in use devices on all my ports, and a few other things.

Any help resolving this problem would be greatly appreciated.
 

DMAN999

Respectable
Herald
Did you do a clean installation of Windows 10 after installing the new motherboard and CPU ?
If not then you really need to.
Leaving the OS installed with your previous hardware will cause issues because there are drivers, etc. left over that no longer apply to your current hardware.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS