Question USB Device not connecting immediately (can take up to an hour)

Oct 14, 2019
22
2
15
0
I have a USB DAC that has been working fine for over a couple of years now. But recently for some reason, windows wont detect it straight away. The light on the device is red, but once the PC has been on for maybe an hour or so the light will switch to green and I get the windows "device connected" sound, like plugging in a usb.

Does anyone have any idea why this is?

Things I have tried:
I have reinstalled the driver
I have updated windows
I have tested the DAC on a separate PC and it works normal

still no luck, any advice would be much appreciated
 
I have a USB DAC that has been working fine for over a couple of years now. But recently for some reason, windows wont detect it straight away. The light on the device is red, but once the PC has been on for maybe an hour or so the light will switch to green and I get the windows "device connected" sound, like plugging in a usb.

Does anyone have any idea why this is?

Things I have tried:
I have reinstalled the driver
I have updated windows
I have tested the DAC on a separate PC and it works normal

still no luck, any advice would be much appreciated
Have you tried a different USB socket?
I also would try a different USB cable.
 
Oct 14, 2019
22
2
15
0
Yes I have tried different USB Cables and Sockets and no luck.

I feel like trhis is more of a software problem as it worked perfectly on a separate computer
 

ASK THE COMMUNITY

TRENDING THREADS