Usb device not recognized (Mass Storage) but optical mouse works



i tried these steps.
Click Start, click Run, type regedit, and then click OK.
2 Locate and then click the following key in the registry: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USB
3 On the Edit menu, point to New, and then click DWORD.
4 Type DisableSelectiveSuspend, and then press ENTER.
5 On the Edit menu, click Modify.
6 Type 1, and then click OK.
7 Restart the computer.

but there are so many usb folders in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USB
dont know which one to edit.


Hello there

As Microsoft recommends, you should never play with the registry settings if you are not very sure what you are doing.

I would suggest to revert the registry back to its original state (remove any created entries, DWORDs, etc.) and try this:

- Open Run command box (press Windows + R keys simultaneously).
- Type GPEDIT.MSC and press Enter.
- Go to Computer Configuration > Administrative Templates > System > Removable Storage Access.
- Here, double-click the All Removable Storage class: Deny all access option.
- Click to select the Disabled radio button and click OK.
- Do the same under User Configuration by going to User Configuration > Administrative Templates > System > Removable Storage Access.
- Finally reboot your system.

It is likely that the issue would be resolved.

Let me know if this was helpful.


Jun 27, 2013
no it didnt work .
when i go to devices and printers > right click on removable device > properties > hardware > properties > general tab.

under general tab device status is
Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

{Unable to Load Device Driver}
%hs device driver could not be loaded.
Error Status was 0x%x



Did you try using any other USB mass storage device?

Many times Windows fails to recognize some old USB storage drives due to obsolete drivers. If any other USB mass storage drive is well recognized by Windows, the issue might be with the one you are using. In that case you need to look for the appropriate drivers for your USB storage device manually.

You can try downloading latest Driver Pack Solution (any edition) from and running it while keeping your USB connected to the computer.

You can also try using a USB hub to connect the USB storage device to the computer. In this case, the computer may detect the drivers of the USB hub and the hub may work as an interpreter between your USB storage device and the operating system.

The issue should be resolved by using any of these methods. Good Luck. :)


Jun 9, 2013
looks like corrupted driver problem to me.

Try cleaning up all the USB device drivers using the


1: First of all remove all the USB devices
except keyboard and mouse
2: download and extract the tool
3: copy the respective version(32bit or 64bit) of tool to c:\windows\system32\
4: open elevated command prompt
5: Type drivecleanup.exe and press
6: wait until it completes, after that

just restart the computer to plug the mass storage device back in

let me know if it helps


Nov 6, 2013
On my Windows Vista Premium Laptop, all USB ports refused to work with memory sticks showing them as 0Mb storage and always asking to be reformetted. My wireless mouse dongle was fine however. After 3 days of trying all sorts of suggested solutions I eventually found one that worked. It comprised:

With just one of your USB sticks plugged in, Open Device Manager.

In Universal Serial Bus controllers look for Mass Storage Device and select it. Open it's "properties" and select the "details" tab. Click the down arrow and look in the drop down list for anything to do with Lower or Higher Filters. Note any such name/value pairs you find.

It seems if you have any filters on the usb mass storage device it will stop it from working.

Now open Regedit and search the complete registry for the "value" found above. You want an entry where it is used as a lower or higher filter.

Delete any such lower or higher filter entries found in the registry.
I had just one in

Use F3 to find next occurrence to make sure there are no others.

Repeat for all filters you don't want.

As soon as I had deleted these filter entries my USB sticks all worked fine without even rebooting the PC!!

Good Luck
Nov 19, 2018
Like yourself I too dug deep into just about every available forum to find an answer to this problem, and all the cyberspace suggestions did not work at all.
Anyway, I finally tested my own solution to this problem and it worked.
Here it is ... plug in any sized USB flash drive into the back of the computer, and let it reside there permanently.
Reboot your computer and then use the front USB socket/s and you will hear the usual sound of recognition first and the icon will appear in the system tray as usual.
Now you can test it by unplugging it in the safe way, wait a few seconds and plug it in again and you will be surprised to see it work no matter how many times you unplug it and plug it back again.
Hope this has resolved everyones USB problems.