Question USB devices have weird lag ?

Aug 26, 2022
25
0
30
0
Hello everyone and thank you in advance for coming to help,

Since my PC's birth it has had issues with the USB devices I plug into it. I don't know if it goes deeper than that. No matter what I am doing the devices will all disconnect and reconnect. This includes the RGB lighting on motherboards devices i.e. the corsair CPU cooler light and the GPU lighting. I'll have bad audio feedback when it all resets. It has not taken over 5 seconds for them to come back but as a gamer that is quite an inconvenience. I also feel like the pc doesn't play as well as it should. I'll be playing CIV 6 and on the bigger maps it starts to really struggle. I updated bios and reset CMOS a couple days later i dont now if that does anything.

ASUS ROG Crosshair VIII Dark Hero
Ryzen 9 5950x
EVGA FTW3 GeForce RTX 3080 Ti
EVGA Supernova 1300 G+, 80+ Gold 1300W, Fully Modular
Hydro x series water cooled. Cpu, EK-Quantum Vector FTW3 RTX 3080/3090 D-RGB and active backplate
2 360mm radiators, 6 fans, one pump.
 
Aug 26, 2022
25
0
30
0
Any old USB devices?
Anything acting strange apart from the USB thing?

Could be a conflict or a USB device that stops responding forcing the rest to disconnect

Its not one reason - power. I doubt a 1300w PSU would be cause unless its faulty

Do any events show in event viewer at time?

try running this and see if you have any latency - https://www.resplendence.com/latencymon
The oldest USB device I have plugged in is a c920 from a few years ago. I have now unplugged it to give it a try as it did have frayed outer wire that I had repaired.
Outside of the laggy games at times as well I don't notice anything. I'll get audio distortion and frame freeze when playing bigger scenarios on Civ 6 and I'll get get audio cut out and and frame stuttering when playing games like Escape from Tarkov.
Lately I've been getting pointer stuttering and audio cutout right out of start up.
Error setting traits on Provider {8444a4fb-d8d3-4f38-84f8-89960a1ef12f}. Error: 0xC0000001 is a main one for kernel-event tracing.
I also have errors in VSS, Server, TPM, and Microsoft Office 16 Alerts.
Is there a a certain version to get for the latency test?
 
Aug 26, 2022
25
0
30
0
The oldest USB device I have plugged in is a c920 from a few years ago. I have now unplugged it to give it a try as it did have frayed outer wire that I had repaired.
Outside of the laggy games at times as well I don't notice anything. I'll get audio distortion and frame freeze when playing bigger scenarios on Civ 6 and I'll get get audio cut out and and frame stuttering when playing games like Escape from Tarkov.
Lately I've been getting pointer stuttering and audio cutout right out of start up.
Error setting traits on Provider {8444a4fb-d8d3-4f38-84f8-89960a1ef12f}. Error: 0xC0000001 is a main one for kernel-event tracing.
I also have errors in VSS, Server, TPM, and Microsoft Office 16 Alerts.
Is there a a certain version to get for the latency test?
I also have Windows 11
 
Aug 26, 2022
25
0
30
0
7.2 is the version I use of Latencymon

tpm errors?

Have newest chipset drivers?
https://www.amd.com/en/support/chipsets/amd-socket-am4/x570
The TPM error says this. Event ID: 12 "The device driver for the Trusted Platform Module (TPM) encountered an error in the TPM hardware, which might prevent some applications using TPM services from operating correctly. Please restart your computer to reset the TPM hardware. For further assistance on this hardware issue, please contact the computer manufacturer for more information."

The Latency test said this so far
"Conclusion: Your system seems to be having difficulty handling real-time audio and other tasks. You may experience drop outs, clicks or pops due to buffer underruns. One or more DPC routines that belong to a driver running in your system appear to be executing for too long. One problem may be related to power management, disable CPU throttling settings in Control Panel and BIOS setup. Check for BIOS updates. "

I am currently updating my drivers. I use driver easy and thought it would have done that. Thank you!
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,254
5,051
166,290
10,413
can you show screenshot of the front of latencymon - upload to an image sharing website and show link here. Curious what it thinks is using most. And which score is highest.

don't use 3rd party driver updaters, they can make mistakes and install the wrong drivers.
Sure, Asus Armory Crate not best updater but its better than others... sometimes.
 
Reactions: Rdeath
Aug 26, 2022
25
0
30
0
can you show screenshot of the front of latencymon - upload to an image sharing website and show link here. Curious what it thinks is using most. And which score is highest.

don't use 3rd party driver updaters, they can make mistakes and install the wrong drivers.
Sure, Asus Armory Crate not best updater but its better than others... sometimes.
LatencyMon

And okay thnk you! So should I just go to the sites to keep checking for updates or is there a better method?
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,254
5,051
166,290
10,413
Nvidia is always at the top, even on a functioning system, but it can also be the problem as you seem to be seeing.

It could be a conflict with another driver or even bios settings slowing Nvidia down.
It can take a while to figure out too as its not causing an error the system sees.

Drivers: generally you don't need to be on the newest drivers. Just staying on ones that work can be all you need. Only update if you are having problems as new drivers can actually cause problems you weren't having.

Ideally you would go to here: https://rog.asus.com/au/motherboards/rog-crosshair/rog-crosshair-viii-dark-hero-model/helpdesk_download/
But Asus are slack and don't always have the newest drivers so I generally go to the source. I.E., if its an Intel driver I run their driver updater, if its a Realtek lan driver I go to their site. If you not sure, you can always ask on here.

Now Latency can be caused by
  • Audio Drivers
  • LAN Drivers
  • GPU Drivers
  • BIOS
You have newest BIOS so can't fix that.
I don't actually know what drivers you have installed so

Can you download and run Driverview - http://www.nirsoft.net/utils/driverview.html

All it does is looks at drivers installed; it won't install any (this is intentional as 3rd party driver updaters often get it wrong)

When you run it, go into view tab and set it to hide all Microsoft drivers, will make list shorter.

Please take a screenshot from (and including)Driver name to (and including)Creation date.

upload it to an image sharing website and show link here

once I know that I can suggest updates.
 
Last edited:
Reactions: Rdeath
Aug 26, 2022
25
0
30
0
Nvidia is always at the top, even on a functioning system, but it can also be the problem as you seem to be seeing.

It could be a conflict with another driver or even bios settings slowing Nvidia down.
It can take a while to figure out too as its not causing an error the system sees.

Drivers: generally you don't need to be on the newest drivers. Just staying on ones that work can be all you need. Only update if you are having problems as new drivers can actually cause problems you weren't having.

Ideally you would go to here: https://rog.asus.com/au/motherboards/rog-crosshair/rog-crosshair-viii-dark-hero-model/helpdesk_download/
But Asus are slack and don't always have the newest drivers so I generally go to the source. I.E., if its an Intel driver I run their driver updater, if its a Realtek lan driver I go to their site. If you not sure, you can always ask on here.

Now Latency can be caused by
  • Audio Drivers
  • LAN Drivers
  • GPU Drivers
  • BIOS
You have newest BIOS so can't fix that.
I don't actually know what drivers you have installed so

Can you download and run Driverview - http://www.nirsoft.net/utils/driverview.html

All it does is looks at drivers installed; it won't install any (this is intentional as 3rd party driver updaters often get it wrong)

When you run it, go into view tab and set it to hide all Microsoft drivers, will make list shorter.

Please take a screenshot from (and including)Driver name to (and including)Creation date.

upload it to an image sharing website and show link here

once I know that I can suggest updates.
Well I thank you for your help and I greatly appreciate it.
Okay thank you for that info on that! I'll have to make a list of the manufacturers so I can go to each site.
I'm trying to become more of an expert.
Could I have updated BIOS wrong?

DriverView

Here is the screenshot.
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,254
5,051
166,290
10,413
if you updated BIOS wrong, PC wouldn't work.

I see they updated the Samsung nvme drivers (its been a while, yours are newer than mine)
well, your drivers are pretty much up to date now.
Realtek Audio - version 6.0.9360.1 - newer than what I am using
LAN - WIFI is dated 5th September 2022
Ethernet - 2nd September 2022
Nvidia - 26th August 2022

What Creative hardware do you have?
Curious what this is for:
driver: CTiAIo64.sys - shows as Creative Technology but Google suggests could be virus?

Try running Malwarebytes or Bitdefender Free and see if they find anything
Probably a new version of Icue
 
Reactions: Rdeath
Aug 26, 2022
25
0
30
0
if you updated BIOS wrong, PC wouldn't work.

I see they updated the Samsung nvme drivers (its been a while, yours are newer than mine)
well, your drivers are pretty much up to date now.
Realtek Audio - version 6.0.9360.1 - newer than what I am using
LAN - WIFI is dated 5th September 2022
Ethernet - 2nd September 2022
Nvidia - 26th August 2022

What Creative hardware do you have?
Curious what this is for:
driver: CTiAIo64.sys - shows as Creative Technology but Google suggests could be virus?

Try running Malwarebytes or Bitdefender Free and see if they find anything
Probably a new version of Icue
Oh haha okay.
Okay so I dont need to update anything. That's good.
I downloaded Malwarebytes and ran the scan it came up with zero threats detected.
Creative Hardware DriverView Advanced
Malwarebytes Scan
Here are some screenshots.
if it helps the code on my motherboard is 9E
the book says its "reserved for future AMI codes"
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,254
5,051
166,290
10,413
I'm sorry I'm not much help I did everything I knew and I'm still learning how to diagnose pcs.
You going fine :)

The code was reserved when Manual was released, its since been made live to show TPM is enabled.

If you don't have any Creative and a search of Astros doesn't seem to suggest they use the drivers, we can stop them loading with windows and see if that helps
Download Autoruns and run it as admin (its from Microsoft so pretty safe) - https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns
This shows everything that auto loads with windows.

Go to drivers tab and find ctiAIo64.sys and untick the blue box next to it, that will stop it running with windows but if anything needs it, it can be started
You can also use this to uninstall the driver but we see how it goes just disabling for now.
 
Reactions: Rdeath
Aug 26, 2022
25
0
30
0
You going fine :)

The code was reserved when Manual was released, its since been made live to show TPM is enabled.

If you don't have any Creative and a search of Astros doesn't seem to suggest they use the drivers, we can stop them loading with windows and see if that helps
Download Autoruns and run it as admin (its from Microsoft so pretty safe) - https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns
This shows everything that auto loads with windows.

Go to drivers tab and find ctiAIo64.sys and untick the blue box next to it, that will stop it running with windows but if anything needs it, it can be started
You can also use this to uninstall the driver but we see how it goes just disabling for now.
Thank you!
Awesome i went to the site and saw that thank you!
I did that and ran it but I cant find the ctiAIo64.sys driver there.
Here is a screenshot of Autoruns
Autoruns
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,254
5,051
166,290
10,413
driver viewer shows all non Microsoft drivers on PC. It doesn't know if they active or not.
It seems the Creative driver is on your PC but not active.

I am starting to wonder if I am getting anywhere.

is the USB thing all the time or just randomly?

did I ask, do you use WIFI or Ethernet as disabling the one you don't use can help with latency and maybe the other thing.
 
Reactions: Rdeath
Aug 26, 2022
25
0
30
0
driver viewer shows all non Microsoft drivers on PC. It doesn't know if they active or not.
It seems the Creative driver is on your PC but not active.

I am starting to wonder if I am getting anywhere.

is the USB thing all the time or just randomly?

did I ask, do you use WIFI or Ethernet as disabling the one you don't use can help with latency and maybe the other thing.
Yeah I'm sorry it really stumps me as to why its happening.
The USB thing happens every time I use my pc. It happens sporadically while its on though.
I'm sorry if this is wasting your time.
I use ethernet and I just turned the Wi-Fi off.
 
Aug 26, 2022
25
0
30
0
driver viewer shows all non Microsoft drivers on PC. It doesn't know if they active or not.
It seems the Creative driver is on your PC but not active.

I am starting to wonder if I am getting anywhere.

is the USB thing all the time or just randomly?

did I ask, do you use WIFI or Ethernet as disabling the one you don't use can help with latency and maybe the other thing.
Wait I found it. There was a default filter
Autoruns CTIAIO Driver Found
 

Mariusglock

Commendable
Jun 13, 2020
162
27
1,640
9
Since you have these problems on win11, I would suggest you make a clean reinstall to win10, could be while you upgraded to 11 some drivers became somewhat corupted. Win 11 is still overrated at the time, and causes quite a bit of issues to some users.
It is a long shot, but might be worth while to try.
 
Reactions: Rdeath
Aug 26, 2022
25
0
30
0
Since you have these problems on win11, I would suggest you make a clean reinstall to win10, could be while you upgraded to 11 some drivers became somewhat corupted. Win 11 is still overrated at the time, and causes quite a bit of issues to some users.
It is a long shot, but might be worth while to try.
What if i started with windows 11?
 

ASK THE COMMUNITY