USB Flash Drive not showing up in BIOs

Spartan191

Honorable
Aug 25, 2013
50
0
10,640
2
Hey guys, I'm making the move up to windows 8.1 from windows 7 but here's my problem. I have everything ready to go for install but my problem is when I start up and go into bios to select my flash drive as the bootable device says disabled. How would I go about enabling it?

EDIT: My mobo is a Asus Crosshair V Formula Z
 

Spartan191

Honorable
Aug 25, 2013
50
0
10,640
2


No, it's just your usual flash drive. I did just check and there is not one.
 

Spartan191

Honorable
Aug 25, 2013
50
0
10,640
2
Ugh, went through hell today. Last night I got it to boot up and was ready to install. The installer prompted me to format my hard drive so I did, then it told me it could not install. My backup was basically erased with my Windows 7 OS, and I didn't have a recovery disc (that I could find, at one point I did.) So I got W7 and then it told me my HDD was gpt partioned. Given up all hope, then I threw in an old hdd from a computer I haven't popped open in 2 years. Worked like a charm, first thing I did was fix my 1TB I would've preferred to have it on. Not going through that again, I'll wait until windows 9 arrives thank you very much.
 

mamasan2000

Honorable
Jan 13, 2014
1,403
0
11,960
219
Did you try booting via UEFI? At least my mobo has the options Legacy or UEFI or Both.

Also, may not apply here but I had trouble with USB devices in Linux. No USB device worked, no keyboard, mouse or anything...until...I enabled IOMMU in BIOS.
 

Spartan191

Honorable
Aug 25, 2013
50
0
10,640
2


Yeah, I tried every setting imaginable.
 

mamasan2000

Honorable
Jan 13, 2014
1,403
0
11,960
219
In BIOS

Under Advanced tab

Legacy USB support - Enabled
USB ports - Enabled


Under Boot tab

USB support - FULL Initialization (the other settings wont detect ALL your USB-devices)

Also check the "OS Type". It has 2 options, Win UEFI and Other OS. Try switching that too if the above didn't work.
 

IronStallion

Commendable
Feb 17, 2016
2
0
1,510
0


Thank you!!! solved my problem

 

theonlyalterego

Commendable
Apr 4, 2016
3
0
1,510
0
I just wanted to comment that I had a similar problem for the last few days and here is what I had to do to solve it:

1. I own a DVD copy of Windows 7 Ultimate - create an ISO of the DVD
2. Use microsofts USB utility to create the USB installer
3. Use INTELs utility to load the USB 3.0 drivers into the images on the USB installer
https://downloadcenter.intel.com/download/25476/Windows-7-USB-3-0-Creator-Utility
Note: this took a while, probably at least 20+ minutes to complete, but it did work.
4. on the target PC connect the USB installer to any USB 3.0 port and install.


The problem that I was having was my new MoBo had only 2 legacy USB 2.0 ports, but I had my USB keyboard and mouse connected to USB 3.0 ports. Windows was having trouble detecting them because it could tell they were on ports it didn't have drivers for. I realised this because during the "failing" installs (which we failing with the "driver required" messages) my mouse was moving very lethargically "generically" you might say. However, after installing the USB 3.0 drivers, and user the "fixed" USB installer my mouse was responding rapidly as I would have expected.

I believe that as a workaround users should TRY and unplug everything from any USB port except a legacy USB 2.0 port. In my case I would have had to remove my keyboard while insalling windows and just use the mouse, and hopefully hot-swap them back and forth. I am not even sure that would work, so good luck if you try that. Otherwise, I suggest you use the linked intel utility to load the USB 3.0 drivers onto you existing Windows 7 USB Installer.


Hardware:
Gigabyte GA-Z170X-Gaming 3 ATX LGA1151 Motherboard

USB Keyboard
USB Mouse
USB Thumbdrive loaded with Microsoft Windows 7 Ultimate 64bit
 

gnguralnick

Commendable
Oct 10, 2016
2
0
1,510
0


I tried all of that, but the USB still doesn't appear in my BIOS. I have used software to verify that it is bootable. Help?
 

Ramjisun

Commendable
Dec 4, 2016
1
0
1,510
0
In Bios, go to hard disk and select the 1st hard disk as your USB drive and second hard disk as your computers hard disk. Then go to boot device priority and the USB option will be visible; you may set as the 1st boot device.
 

Similar threads


TRENDING THREADS