[SOLVED] USB flash drive Write Protected but cant clean, no bad sectors


Nov 18, 2020
I have a SanDisk Ultra USB 3.0 32GB and after putting some data on it yesterday, when I reconnected it said it was "Write protected".

Steps I've already taken:
Formatting using windows, but it failed.
DISKPART attribute disk clear readonly which outputs "Disk attributes cleared successfully." without actually removing Write Protection.
DISKPART clean and got "DiskPart has encountered an error: The request could not be performed because of an I/O device error. See the System Event Log for more information." (not sure where the logs are)
S.M.A.R.T shows healthy disk
I tried to set the registry key for HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies\WriteProtect to 0 with no luck.
Ran chkdsk F: /f /r /x and I got "The type of the file system is FAT32. Windows cannot run disk checking on this volume because it is write protected."
Then I used AOMEI Partition Assistant Standard which I tried to format the drive and it gave an error code 106 ( ) which means "The above error codes are generally due to physical disk errors like bad sectors."
However, I scanned the drive with HD Tune and there are no bad sectors.

Some things that might be important:
I don't think that there is a physical lock unless it is hidden inside the USB...
I have software on that flash that Bitdefender detects as malware, but doesn't seem to be able to remove it. Also, the detected software shouldn't cause the drive to Write Protect.
OS Windows 10 x64
The drive is about a year old and had almost no use.
I am 99% sure it is genuine since I found the retailer that I bought from on their resellers list.
I've tried it on different PC.

I am considering running the MHDD, but I doubt that will help since HD Tune shows no bad sectors. I might also try booting to Linux and try to recover it from there. I will also try EaseUS Partition Master.


May 11, 2008
A write protected message usually means that the drive has gone bad. The firmware has gone into write protect mode to prevent loss of existing data but no longer accepts write attempts. It's irreversible.