Question USB not detected and unable to format

Sushrut_Thakur

Reputable
Jul 14, 2016
19
0
4,510
0
Context:
I have a Sandisk Extreme USB 3.0 pen drive which I use to install Operating systems. I make it bootable with PowerISO and I format it to use as my regular pen drive.
Recently I came upon this tool called balena Etcher which creates "live" USB of any Linux distros. I was installing an Ubuntu-based distro called Zorin OS and thought I'd give it a try.
I followed the standard procedure (not that there's anything to follow. Just select iso, select pen drive and click start.) and installed Zorin on my laptop. I didn't notice anything different than how I used to do it with PowerISO so I don't know what this "live" thing is all about.
So now, I was trying to install Ubuntu 18.04 on another machine, and I was gonna use the same pen drive. I didn't format it as I thought it would automatically be formatted during the procedure. I inserted the pen drive and tried using Etcher the same way as last time.
But this time, Etcher was unable to format the pen drive. It just hung so I closed it.

Now to the main question
I can't see the pen drive listed in 'This PC' but I can see it listed in Disk management.
The whole space is unallocated. When I try to create a partition, it creates a RAW partition and I can't use it.
I can't format it as it says "Windows was unable to format". I deleted and recreated the volume but it's still RAW.
Using diskpart makes no difference, it's still not able to format.









This is the error when I try to format the created RAW partition



The 2 errors that I get when I try to create a partition are
1. The partition was created but was not formatted. Try formatting again



2. The system cannot find the file specified



Could someone please guide me through how to get my pen drive pack?

PS Other pen drives are working in the same slot, so it's not the drivers or the slot.
 

hang-the-9

Titan
Moderator
Sounds like a bad drive. When you said you tried diskpart did you do a "clean" command on the disk drive then try to format it? Another option to try is to clean it with diskpart and try to format it on a Linux OS.
 

ASK THE COMMUNITY

TRENDING THREADS