Question USB not enough power to supply VR and other devices ?

Oct 23, 2021
1
0
10
0
Currently my motherboard is a b450 tomahawk paired with a 2700x and a gtx 970 I came to the conclusion that my USB is having problems after my USB ports started not working and having problems. Before this problem occurred I was able to plug in all devices to my USB ports but now most USB ports only work with my mic a blue yeti. The other devices I tried plugging in is my keyboard but as soon as I did the keyboard blinked red and gave no inputs. This was the same with my headphone amp giving no power. I originally found this issue out after my Oculus Rift S would have no connection to my pc but was still detected by it.

What is strange is I checked all of my USB Power data and found all of them stating they're at D0 power level so I'm questioning rather this is a power issue.
I bought the motherboard 2 years ago so it would strange for the board to be dying now.

I have a feeling it could be my power supply because it is old being bought in 2014. The power supply I have is a corsair 750 watt power supply but the only problems I have had so far is the USBs. One solution I tried was to update my USBs in device manager but all of them were up to date along with my other drivers I also updated my bios to the newest stable version but it made no difference. I would be grateful for any recommendations and guidance on how I can fix this issue
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS