Question USB Ports disabled when USB Hub is plugged in (Asus Prime Z390-A)

Apr 25, 2019
1
0
10
0
Specs:
Code:
Motherboard:    Asus Prime Z390-A
CPU:            Intel i5-9600k
Graphics Card:  Asus Dual GTX 1070
RAM:            Corsair LPX Vengeance 3200Mhz (2x8GB)
SSD:            Samsung 860 EVO 500GB
HD:             WD Black 2TB 7200RPM

USB Devices:
        USB Keyboard:   Das Keyboard 4 Professional
        USB Mouse:      Logitech G502
        External HD:    LaCie Hard Disk 1TB USB 2.0 External Hard Drive (off)
        USB Hub:        Dell S2719DGF (populated with below)

                        USB Hub:        Sabrent Premium 7 Port Aluminum USB 3.0 Hub with 5V/4A Power Adapter (Empty)
                        USB Webcam:     Logitech HD Webcam C310
This is my current setup, and the problem that I'm experiencing is that when the Dell USB Hub is plugged in, my keyboard and mouse are not powering on properly until a few seconds after the system boots into Windows. Once in Windows everything works properly. I have tried unplugging everything from the Dell USB Hub, and various configurations of USB 2.0 and 3.0 ports for all devices. I have tried all combinations of Fast Boot, XHCI Hand Off, and Legacy USB both enabled and disabled. It is definitely just this one USB Hub, and I'm assuming that at power on it is overloading the available power.

I know the obvious workaround is to just unplug the Dell USB Hub when I want to go into BIOs, but I would rather find a way to just make it work. Has anyone else seen anything like this, and have you been able to get it to work properly?
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS