USB Ports Dont Work ?

Phoenix MT

May 27, 2014
Soo I built a new PC and something odd just happened that never did before, My mouse and Keyboard were working fine then I decided to do the update on the USB ports so i can use USB 3.0 on my motherboard then suddenly they stopped working, all usb ports stopped working, it works fine in the BIOS and before the windows startup but I couldnt do anything even went inside the BIOS settings and looked at the USB options but still couldnt make them move, I also tried Safe mode Nothing !, so i had to clean install the windows again now I dont wanna do the USB update again but I am only stuck with 2 ports and they are not even 3.0 anny suggestions on what I can do in order to update my USB software and actualy be able to move XD, my MOBO has a PS2 connector but I dont have a handy PS2 mouse

Also while I am here My mouse middle scroll button doesnt wanna scroll up or down and Yes I tried different mouse still nothing and tried them both on another PC and they worked, these things are Making me go Crazy !!!

Motherboard - MSI Z370
OS - Win 7


Nov 7, 2008
Go to
Get the "Intel USB 3.0 eXtensible Host Controller Driver for Intel 8/9/100 Series and Intel C220/C610 Chipset Family." Driver.
Install, live free.

I'm happy to say I found a solution to this. I was lazy (and I had things set up the way I like them) and just shoved a working Win7 install on a SSD onto my Gigabyte HD3P Z370 board. I was able to get all the drivers from Gigabyte's website to install. However, I could only get the Mouse and Keyboard stuff to work through the 2 USB ports specifically designed for that. Although it was irritating that the scroll wheel refused to work, just like yours. Was like I only had a 3 button mouse installed sans scroll wheel. Very maddening! There was also a yellow sign in the device manager for the Universal Serial Bus Controller....

I called up Gigabyte and they gave me the same answer that everyone else has: Do a fresh install with the special USB driver insertion trick that's already been mentioned.

I refused to give up because I could nearly taste victory. After many hours of poking around and irritation, I found the Intel page in the link above. I figured "Couldn't hurt to try, and the newer version is probably the right one." There was a bit more to it than that, but I don't know that we need to get into that. Low and behold I now have working USB ports. Happy dance!

Of course Windows is going to gripe about new hardware, but as long as you have additional activations available for your install you should be golden.

Bit of information about my setup:
Core i5-8400
Kingston SSD
Win 7 Enterprise (However, this should work with any version of Win 7 would be my guess)

Edit: Fixed a bit of grammar and wording.