Question USB ports drop intermittently after mobo upgrade

bmaddock

Distinguished
Oct 29, 2010
4
0
18,510
0
Windows 10 64-bit build 19042
MSI B550 Gaming Edge Wifi MS-7C91 mobo
AMD Ryzen 7 3700x CPU
Corsair HX750 PSU
Anker 10 Port 60W Data Hub with 7 USB 3.0 Ports

All - Hoping someone can help as I'm at wit's end. I recently upgraded my mobo and processor, as I'm getting into photography and needed something to handle the demands of photoshop. I also have 7 (!) external hard drives plugged into the Anker hub that previously connected to a USB 2.0 port on the old mobo.


Since upgrading, the PC intermittently drops one or all of the external drives, seemly at random. I have tried:

  • deleting & reinstalling USB through Device Manager (all of them)
  • updating ALL drivers (using Driver Easy)
  • disabling "allow the computer to turn off this device" in USB > Properties > Power Management
  • disabling USB selective suspend setting under Advanced Power Settings
  • trying different USB ports (USB 2 and 3)
  • replacing the USB hub
  • replacing the mobo (yes, I did that)
possibly unrelated: The mobo is running in CSM (compatibility support module) mode, as I haven't had the re$ources to upgrade my old graphics card yet.

Any and all help is greatly appreciated.
 

bmaddock

Distinguished
Oct 29, 2010
4
0
18,510
0
Since your reply I have done a clean Windows 10 install. I've also split the external drives across 2 usb hubs (three drives each), and plugged the last drive directly into another USB port on the mobo. I'm still getting intermittent drops, although less frequently. I also replaced the powerstrip powering the USB hubs. At this point I can't think of any other hardware related causes. The drivers are all current as well.
 

ASK THE COMMUNITY