Question USB ports giving power but keyboard and mouse doesnt work

Oct 25, 2020
2
0
10
0
i had this sudden blue screen and after my pc got reatarted my usb ports stoppet working, it gives power but doesnt seem to reposnd to my mouse or anything. And a wierd thing is when im in the BIOS my keybard actually work fine but when i boot up into windows it stops working, same woth the mouse
 
Oct 25, 2020
2
0
10
0
Forgot, i have a Lenovo Y710 Desktop ita about 3-4 years old and specs
i5 6400
Lenovo H170 Motherboard
MSI geforce gtx 1060 6gb
8gb ram
Powersupply, It doesnt say what brand but says 500w 80 Bronze plus
 
Nov 19, 2020
3
0
10
0
I have a similar problem. My mouse and keyboard works in BIOS but does not work anywhere else. It was working perfectly fine the night before but in the morning the problem suddenly came up. I've done some research online and tried the following:

  1. There is power to all my USB ports. Numlock on keyboard flashes every time a key is pressed.
  2. Computer cant read my USB mouse and keyboard at windows log-in page
  3. Computer cant read my USB mouse and keyboard at windows installer when booting from a thumbdrive to reinstall windows (it gets to the installer page though)
  4. Both keyboard and mouse works in BIOS
  5. Legacy USB is enabled in BIOS.
  1. Tried removing all USB devices and replugging at log-in page (not solved)
  2. Reset CMOS (not solved)
  3. Flash BIOS (not solved)
  4. Tested mouse and keyboard on other computers (works)
  5. Tested other mouse and keyboard on faulty computer (not detected)
  6. Tried hard reboot (haha not solved)
  7. Tried using USB 2.0 ports and USB 3.0 ports (not solved)
Note: I cannot use remote access as I have no pre-installed software for this on my desktop like Chrome Remote or TeamViewer. So updating drivers is not an option

Note2: I dont have a PS/2 mouse/keyboard either I've tried looking and asking around.

My conclusions so far:
-Not OS/Driver issue cause doesnt work on bootable thumbdrive
-Not BIOS issue cause reset and flash BIOS did not help
-Not hardware issue cause everything works in BIOS and my USB ports can read any thumbdrives (and provides power to peripherals)
- Not peripheral issue because they work on other computers

Specs:
Mobo - Gigabyte z97x UD3H
OS - Windows 10
Can't really remember the rest... PC is 6+ years old and I've thrown the boxes

I'm quite lost to be honest, looking for any other suggestions.

To Membz:
You can try any of the solutions I've tried; some of them have worked for others.
Resetting CMOS and flashing BIOS should be your last resort
Usually using safe mode and deleting the mouse drivers or reinstalling windows are your best bet (if you're sure your peripherals are fine)
 

ASK THE COMMUNITY