Question USB ports not working

icarus2712

Reputable
Jul 6, 2018
77
0
4,540
0
Hi all, I had some external monitor issues which I resolved after updating drivers in windows update ( I had earlier done hp recovery after some issues).
My wifi mouse and keyboard was working fine after and before recovery. Suddenly today after updating windows- I guess- I could not connect to wifi mouse and keyboard.
Trackpad and keyboard of the laptop works fine.
Under device manager I could see yellow triangles under usb serial host( there was some AMD 3 x host controller also) so I uninstalled and restart the machine.
Still any of the usb port not working. Any clues.https://i.postimg.cc/mr9KpC4v/IMG-20201102-230044.jpg
 
Last edited:

xenthia

Distinguished
Sep 20, 2012
183
20
18,665
31
Hi all, I had some external monitor issues which I resolved after updating drivers in windows update ( I had earlier done hp recovery after some issues).
My wifi mouse and keyboard was working fine after and before recovery. Suddenly today after updating windows- I guess- I could not connect to wifi mouse and keyboard.
Trackpad and keyboard of the laptop works fine.
Under device manager I could see yellow triangles under usb serial host( there was some AMD 3 x host controller also) so I uninstalled and restart the machine.
Still any of the usb port not working. Any clues.https://i.postimg.cc/mr9KpC4v/IMG-20201102-230044.jpg
You can try uninstalling those devices including their drivers from device manager and also from the programs and features section in control panel if they have any installers.

This image usually means there is problem with the driver. Maybe it was not signed or maybe suspicious so the new windows update had them removed. Or they are not compatible with this version for whatever reason, or during the installation of a new version of Windows these didn't get properly handled. Uninstalling them and installing them again will probably solve the problem.
 
Reactions: icarus2712
Aug 12, 2020
82
10
45
17
1) Try uninstalling all USBs from the device manager and rebooting your computer. It will be re-installed automatically. Before restarting the computer, make sure the option (device driver install from Windows update) is ON to get the driver automatically from Windows server.

2) Make sure there is no virus or malware on your computer. Scan with good antimalware. Your USB port
 
Reactions: icarus2712

icarus2712

Reputable
Jul 6, 2018
77
0
4,540
0
1) Try uninstalling all USBs from the device manager and rebooting your computer. It will be re-installed automatically. Before restarting the computer, make sure the option (device driver install from Windows update) is ON to get the driver automatically from Windows server.

2) Make sure there is no virus or malware on your computer. Scan with good antimalware. Your USB port

Well I uninstalled and restarted second time still no solution, under device installation settings Incan see" Do you want to auto download manufacturers apps ..." auto set to yes.

Should I reset my pc. I had shrink the c volume and stored my data in new volume.

Will that be erased?
 

csillver

Distinguished
Dec 23, 2009
21
0
18,510
0
Soooo. Im going through a similar issue. Ive uninstalled, tried to update the drivers, all to no avail. Ive done a system restore, but that has not helped. I havent wiped yet, but I did do the light windows reinstall. Windows 10. I have two ports working in the back. With the other ports not working at all. When I uninstall, they come back with the triangles. Does anyone have links to the intel ICH10 family of controllers 3A37?
 

csillver

Distinguished
Dec 23, 2009
21
0
18,510
0
Soooo. Im going through a similar issue. Ive uninstalled, tried to update the drivers, all to no avail. Ive done a system restore, but that has not helped. I havent wiped yet, but I did do the light windows reinstall. Windows 10. I have two ports working in the back. With the other ports not working at all. When I uninstall, they come back with the triangles. Does anyone have links to the intel ICH10 family of controllers 3A37?
 

csillver

Distinguished
Dec 23, 2009
21
0
18,510
0
Dunno why it posted twice... I dont come in often
Regardless. Anyone having this issue. If youre lucky enough to find your old motherboard install disk with chipset drivers, youre in luck. ... We found the disk and did the browse for the file thing.
All ports up and running as if nothing had happened.
 

ASK THE COMMUNITY

TRENDING THREADS