Question USB Ports RESTARTING only when Gaming and trying to use a CONTROLLER

HoT_TaCTiiCtZ

Reputable
Mar 7, 2015
10
0
4,510
0
Okay! So I don't know what's going on but suddenly 3 days ago as I was trying to play CONTROL for the first time, I was in the game with my PS4 Controller (emulating a XBOX Gamepad via DS4 WINDOWS) and suddenly about 5 minutes into the game my PS4 Controller got disconnected but also all the USB ports seemed to restart as well (power went out to keyboard and mouse for 1 second then back on) and from there on out I couldn't get the PS4 Controller to connect back to my PC, I started getting PNP FATAL ERRORS (Plug N Play) and my System would crash when trying to charge my controller on the PC so logically I thought "Okay, something must be wrong with this PS4 Controller" and I uninstalled the device and re-installed it... Long story short, the same problem persisted, then I thought "Well maybe it's THIS PS4 CONTROLLER specifically that has something wrong with it" so I GOT MY 2ND PS4 CONTROLLER CONNECTED... Again, this leads me to the same problem. I am at a LOSS! I don't know what's going on or why it's happening. I was thinking maybe it was just CONTROL (the game) that would give me this problem but it's not! I've tested it in THE CREW 2 and it gets the same problem.

From what I've experienced, It seems like games with HEAVY LOAD on the system somehow messes with the PS4 Controller or the driver or something, I don't know but when I play lower load games with the controller like older titles from 2013 or before I can play for MUCH MUCH LONGER or "INFINITELY" without getting the weird USB port reset.
IMO I think the problem is of the following...



    • The Bluetooth Adapter itself (I should test this by trying to use a Bluetooth headset while gaming!) I've made sure all necessary drivers for it are installed BTW.
    • The Controller's Driver.
    • The PSU or loose/wrong cable placement
I've tried to uninstall the Driver in DEVICE MANAGER for the "XBOX GAME CONTROLLER" but every time I try to, it just says "UNINSTALLING" forever and it never actually says it uninstalls it. For this reason, I am really thinking it's the driver but I'm not sure.

I should also mention that after this happens (The controller disconnecting and all USB ports shutting down and restarting within 1 - 5 seconds) I can play the game PERFECTLY FINE FOREVER WITH MY MOUSE AND KEYBOARD and if I never connect the controller at all and just go into a game intending to play it with my M&K, the USB ports never restart or anything and again, I can play perfectly fine "forever" if I want. I TRIED INPUT MAPPER AND IT STILL HAPPENS SO IT'S DEFINITELY NOT DS4 WINDOWS!

SOoOoO, Yeah! I think the first place I should start is uninstalling the "Xbox 360 Controller for Windows" located in Device Manager > Xbox 360 Peripherals I just need help on how to go about doing that because like I said earlier when I click "UNINSTALL" it just says "UNINSTALLING" forever and ever. 2nd step would be to re-fit all my cables in my build... If this still happens I guess 3rd thing TO-DO would be to get a new Bluetooth adapter right? I didn't even know those things could die/mess up. I've only had it for about 3 years. 4th step (and probably last) would be to get a NEW PSU in case my current one is unstable and the culprit of causing the problems... andddddd if all that is said and done AND I STILL GET THE DISCONNECTING AND USB PORT RESTARTING WHEN TRYING TO USE THE CONTROLLER, it's probably the MB or something wrong with the Windows OS (corruption even though when I run SFC/SCANNOW no corruption comes up!)

Anyway, I just turned this thread into a TO-DO list for myself but IF ANYONE CAN HELP ME OUT I'D BE VERY APPRECIATIVE! I would hope someone has had this exact problem before. IF ANYONE WANTS, I CAN RECORD A VIDEO OF THIS OCCURENCE AND UPLOAD IT TO YOUTUBE TO FURTHER HELP DIAGNOSE MY PROBLEM!


The basic info of my setup is...

1 x RTX 2080 TI
i7 4790K (I know, it's a bottleneck)
2 x 1 TB WD Black Drives
1 x 500 GB Samsung SSD EVO

PSU Is the CX750M, (750w) I got it brand new about 1 - 2 years ago tops.

Side Note: For now I am definitely going to open up my case and re-fit all the wires to see if that's the problem, maybe I plugged in some critical power cable into the wrong slot on the PSU or whatever, I don't know. I know I recently moved my build into a new case around the same time but I can't remember if I had been gaming fine on it on intensive games with my controller or not. I wish I could remember that way I could say that it's definitely not a wiring problem.


UPDATE #1. So I've successfully managed to uninstall the BT software from Device Manager in WINDOWS SAFE MODE, I made sure to tick the box that says something like "Delete Software that was installed with this" and then I reinstalled all the drivers for it on the next reboot. PROBLEM WAS NOT SOLVED AND MY USB PORTS ARE STILL RESETTING. Maybe it wasn't the BT Software (or hardware) after all. Maybe it's something bigger like the PSU or the MB. I noticed since I got on my PC 20 minutes ago all my USB ports seem to be RESTARTING EVERY 5 - 10 MINUTES. Literally EVERYTHING on my PC got shut off and turned back on for a second. Even the LEDs on my SPEC-OMEGA case (the strip that runs through the front panel)

Well, at least I've (seems like anyway) narrowed the problem being down to the PSU, Motherboard, or Corrupted Windows files! I'm still going to see if this problem stops by simply uninstalling some suspected trash software I have installed on my PC. (Starting with GIGABYTE's AORUS ENGINE)

It just really seems like an unstable PSU problem to me (not a professional though) because it's as if the MB or the USB ports, SOMETHING is getting too much power and "overloading" in a sense so it shuts itself off for a second. I've also noticed that now sometimes when the USB ports all shut off, there's like a 20% chance that they NEVER TURN BACK ON UNTIL I REBOOT THE ENTIRE SYSTEM!

Also, before I forget! I did try to play THE CREW 2 with just my Bluetooth earbuds (PowerBeats3) and within 5 minutes the reset happened about 3 times. The thing is, it still reconnected automatically to my BT adapter after a few seconds and I continued playing as normal for over an hour and there were no "hiccups" basically, I don't really know if it's the BT software or BT Hardware causing it as I said a minute ago, IT VERY WELL COULD BE a PSU or MB problem. The only thing that still has me thinking it's the BT Soft/Hardware is the fact that 9/10 times my USB ports shut off right after I connected A BT Device and started gaming (A.K.A putting heavy load on the PSU) This is actually the first time that my USB ports restarted like this without me actually having a BT device connected at the time!


UPDATE #2: Okay something weird just happened, without any BT connections going on at the time. All my USB ports stopped working while I was playing Minecraft but that's not the weird part I guess. The weird part is I was trying to install JAVA 64-bit AT THE SAME TIME (didn't wanna close the game ok? lol) and as soon as the INSTALLATION BAR hit 100% that's when all USB ports shut off, restarted, but left me with no function, like there was power going to everything but at the same time there wasn't because my Keyboard nor my Mouse were working and didn't do so until I rebooted the system. It's really starting to look like the USB software or hardware (Motherboard) is the culprit Next best guess to that would be of course corrupted Windows files or the PSU.


UPDATE #3... 10/1/2019
I should change the title of this thread or whatever because it's not just happening when I'm in a game or when I'm using a controller, I've tested it by downloading and running a GPU stress application (also a CPU stress app) and basically when I left my CPU to run at full load for 30 minutes nothing happened but just 5 minutes into a GPU stress test (did it separately from the CPU stress test, not at the same time) that's when my USB ports shut off and I had to reboot to get them to start functioning again. They provided power to my devices but wouldn't recognize anything. ANYWAY! On to the important thing I've since discovered... It's not the GPU's fault in a way because I've gone ahead and loaded up WINDOWS 10 from my OTHER SSD and that SSD barely has anything more loaded onto it than THE ESSENTIAL SYSTEM FILES... I've run CONTROL at 4K ULTRA settings with RTX on for 30 minutes while playing with a controller and NO USB PORTS SHUT OFF...

I was about to go run out and buy a NEW PSU after reading bad reviews on Corsair's CX series PSU's (of which I own) but I'm now really confident that it's a SOFTWARE issue. Somethings either corrupted or conflicting on my main SSD that's causing the USB ports to shut off primarily when the GPU is under heavy load. I'm wondering if uninstalling the GPU's drivers with DDU and reinstalling might help and/or re-installing the USB software in Device Manager.

I was really thinking it might be that the PSU was failing... or maybe a part on the motherboard was fucked up or even that something was pulling too much power (CPU or GPU) but after having such a smooth experience with no hiccups on CONTROL by simply switching SSD's it can't be that. It's gotta be software related. It's just such a shame that such a devastating problem has arisen on that SSD because I just had to reset the PC on it since something else recently went wrong with some system files on that drive about a month ago. At least I know it's not a hardware problem now. I just wish I knew what the hell it was that's messed up on it and how it happened. I may just make sure I have every installer for every program I need pre-downloaded onto my hard drive and then go ahead and reset Windows on that SSD once again and then spend an hour re-installing every program all over again. (assuming reinstalling the USB software through Device manager or reinstalling the GPU software doesn't work!) If I go through with this reset I'll just have to be really cautious as to what gets installed on my system from now on and make sure to take notes when I notice something odd starts happening... I also gotta make sure I have RECOVERY POINTS saved every 2 - 4 weeks. : l time to load up my other SSD again and test it out some more to see if the USB ports don't shut off.

Update #4... 10/07/2019 Going to keep this simple... This update still agrees with everything I said in my last update on October 1st, 2019. IT IS definitely a software issue as I have already played CONTROL multiple times this past week for more than 5 CONSECUTIVE HOURS at a time with no USB ports shutting down. I finally was able to finish the game! I'm probably going to have to just refresh the OS on that SSD as much as I don't want to have to do that but it's quite obvious that none of my Hardware is at fault here by now. I've gotten NO ISSUES at all since switching to Windows on another SSD. I'm hopeful that when I decide to go back to using that SSD I find the culprit program but I really doubt I'll be able to. :/

Also, if I do refresh/reset Windows 10 on that PC and it still continues to give me USB Port shut-off problems... Somehow it's the SSD itself IMO but I REALLY don't think that will be the case lol. I'll update this again once I reset just to let everyone know what happened. (More than likely, expect the problem to be fixed.)

WIll keep this updated...
 
Last edited:

PC Tailor

Dignified
Herald
Well maybe it's THIS PS4 CONTROLLER specifically that has something wrong with it" so I GOT MY 2ND PS4 CONTROLLER CONNECTED... Again, this leads me to the same problem. I am at a LOSS
Are you using the Scarlet Crush driver for these PS4 controllers? They are renowned for causing various stop errors / crashes. I suspect you may have BSOD disabled and it is simply restarting?
 

HoT_TaCTiiCtZ

Reputable
Mar 7, 2015
10
0
4,510
0
Are you using the Scarlet Crush driver for these PS4 controllers? They are renowned for causing various stop errors / crashes. I suspect you may have BSOD disabled and it is simply restarting?
Scarlet Crush driver? I've never heard of this, how would I go about seeing if this software is installed?! All I know is I use my PS4 Controller, connect it using my plugable BT adapter and then fire up either INPUT MAPPER or DS4 Windows in order to make the controller emulate an XBOX 360 controller, I've been doing that for YEARS and now suddenly this weird shut-off of the USB ports happens (9/10 times when I'm gaming and ESPECIALLY when trying to play a game that's a heavy load on the system.) I really feel like it's the PSU. It basically never ever restarts the USB ports when I'm NOT gaming. I'm possibly going to go get a new PSU pretty soon and if the problem goes away I'll know it was that. I haven't been able to figure out what's causing this and then I just kind of gave up last week. Real shame knowing my RTX 2080 TI is sitting in there not getting put to good use, I'm just so not used to M&K for gaming and most of my games are either Single Player or Racing games so a Controller feels natural for me, not to mention I've had problems with Carpal Tunnel in the past.
 

ASK THE COMMUNITY

TRENDING THREADS