Question USB ports suddenly stop working

Mar 12, 2023
First post, so forgive if this isnt the correct spot

New issue popping up with my build. Out of the blue all but 1 of my USB ports go unresponsive. All the ports on my case - 2 regular, 2 3.0 - and all but 1 of the ports on my motherboard (ASUS Z390). The only one that consistently will work is the first port on the motherboard. Others are totally dead. Only thing I found that fixes it is a complete shutdown, kill the power and wait 15 minutes and half the time that does nothing. At a total loss. One constant I have noticed is my keyboard is always the first to go, and will go unresponsive a few times before all but the 1 port go unresponsive. Keyboard is Logitech G910. Custom lighting/program will stay active for a few cycles of unplugging and plugging back in
No constant to what I am doing with my desktop, i.e gaming or streaming or being idle.

Any ideas as to why or any possible solutions?


Welcome to the forums, newcomer!

What BIOS version are you currently on for your motherboard? As for your platform, perhaps try and see if reinstalling your chipset drivers in an elevated command,, Right click installer>Run as Administrator, helps alleviate the issue.
Mar 16, 2023
Same thing happened to me, and based on recent searches, it seems like it's happening to a LOT of people within the last week. It happened once a few months ago, and fortunately reinstalling the chipset had done the trick. However, this time around, that fix doesn't work anymore. I have to plug in my keyboard to the front panel of my case, as the front USBs are connected to another part of the MB. When I tried to reinstall/update Serial IO, install keeps failing no matter what I do, including compatibilities etc. Last but not least, I updated the BIOS to the F12 version, still nothing. I'm honestly at a loss.

EDIT: I tried unplugging the devices I didn't "care" about and plugging the keyboard in those ports instead, it wasn't working at first, but eventually after a last-ditch attempt the keyboard lit up when plugging it in one of the bottom ports. Whenever I would put it back to the original USB configuration, the second I'd plug in the last device in the last available top port (so all of them would be busy), the keyboard would turn off. After switching the peripherals ' ports around, eventually when getting to the original USB setup, it worked. I have absolutely no explanation, but if I were to give an advice, it would be to reinstall the chipset that's listed under the name on the Gigabyte website for the motherboard, and to just try and move stuff around (if you have peripherals that you wouldn't mind if it wouldn't work after being unplugged, like a charger, I'd recommend starting there if like me you have no free USB port. One thing I did notice though is that the problem wasn't localized to Windows, even when I'd enter the BIOS the keyboard wouldn't work if I unplugged it from the front panel and plugged it to the rear. If you haven't updated the BIOS to the last version already, you should do that too even if it has no influence on the issue whatsoever.

Hope this helped even a tiny bit!

EDIT2: Please note that it took 3 hours after reinstalling the chipset and doing all those gymnastics to get the ports to function again, so be patient!
Last edited: