[SOLVED] USB power problems - speakers, keyboard & mouse not working on startup

Feb 20, 2019
6
0
10
0
Hello, dear community
Here's the issue - when I start the PC, my wireless keyboard and mouse are not working until I pull out and plug back into the USB port the extension cable. The wireless dongle is on an active USB extension cable.
Another issue (again on startup) - static noise comes out of the speakers (hooked to the monitor's USB port) and only left channel is active. Again, after I unplug and plug, everything goes back to normal. Although sometimes the speakers lose the signal again, but the mouse & keyboard are ok all the way until the next startup.
I have several HDDs both internal and external, if that has got anything to do with the power issue.
What do you think the problem is?
Thanks in advance!
 

Ralston18

Titan
Moderator
Try using a self-powered USB hub to connect external USB devices.

My thought is that your system is not able to meet the existing USB power demands required during startup. Especially when everything USB is connected. Plugging (re-plugging) the USB devices one by one avoids that situation.

All works until you restart again with everything connected.
 

Ralston18

Titan
Moderator
Try using a self-powered USB hub to connect external USB devices.

My thought is that your system is not able to meet the existing USB power demands required during startup. Especially when everything USB is connected. Plugging (re-plugging) the USB devices one by one avoids that situation.

All works until you restart again with everything connected.
 

ASK THE COMMUNITY

TRENDING THREADS