• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question USB problems

Jul 2, 2020
9
0
10
0
So I just built my first pc and I have some problems. my USBs on my motherboard and front panel don't work when I turn my pc on. all the fans and stuff turn on also but nothing shows up on my monitor I have cdmi plugged in.
 
So I just built my first pc and I have some problems. my USBs on my motherboard and front panel don't work when I turn my pc on. all the fans and stuff turn on also but nothing shows up on my monitor I have cdmi plugged in.
Some possibilities.
You didn't build it right
Some part is DOA
All parts are not compatible with each other.
Now list your parts so somebody can take an educated guess instead of using crystal ball.
 

ravenscout

Commendable
Nov 21, 2017
12
0
1,510
0

Look for something similar to this in your Motherboard manual (if you lost it like I did, just look the PDF) and make absolutely sure you put these pins in correctly. That was actually my issue, years ago when I first started building.
 
Jul 2, 2020
9
0
10
0
I think I figured it out I do not have the USB 2.0 header plugged in. I do not know where this cord is or if its supposed to be on my case. I looked it up and I can buy one I understand I need to plug it into the motherboard but where else? thank you for your help. Also I think I figured out the problem with the no signal on my monitor when I first installed my graphics card I broke the little clip on the end of the graphics card slot. I broke it all the way off and I don't know if this will be a problem.
 
Last edited:
I think I figured it out I do not have the USB 2.0 header plugged in. I do not know where this cord is or if its supposed to be on my case. I looked it up and I can buy one I understand I need to plug it into the motherboard but where else? thank you for your help. Also I think I figured out the problem with the no signal on my monitor when I first installed my graphics card I broke the little clip on the end of the graphics card slot. I broke it all the way off and I don't know if this will be a problem.
Neither of those would case it not to boot if everything else is right. You better start from beginning. Take evrything out of the case and assemble just MB, CPU with it's cooler, RAM in it's proper place(s) and PSU.
Also help us help you and list all your parts.
 
Last edited:
FINISHED BUILD here are my parts. and I was talking about the USB cords because my USB ports don't work. and I think it was the graphics card that is messing me up.
FINISHED BUILD here are my parts. and I was talking about the USB cords because my USB ports don't work. and I think it was the graphics card that is messing me up.
Everything is compatible so I would proceed as I proposed. it's always possible to have some short to the case.
 

ASK THE COMMUNITY

TRENDING THREADS