USB Stick unable to be formatted after encryption

Dec 10, 2018
2
0
10
0
Hello guys!
I recently dug through my old stuff and found a long lost flashdrive. Once i found it, i remembered that it had been encrypted with bitlocker. Since then i have upgraded my pc, but i have my operating system on home version (Windows 10 home) instead of the previous pro edition (Windows 10 pro)
Since bitlocker is usable on enterprise and pro, i have no easy way of atleast looking in to the flash drive. I thought i would just format it using the built in windows function, since it suggests it when i plug it in. I tried formatting it, but every time i go to open the file explorer, it just hangs and doesnt let me do anything, unless i unplug the usb stick and then it works just fine. I tried other programs that help with formatting drives,such as AOMEI partition assistant, that one didnt atleast crash when i opened it, when i got to format the drive, the program starts doing its thing, and then just hands on one particular procentage and stops, although the usage indicator keeps flashing. Also, i tried using the windows disk managament program, and that also hangs and, after a bit, says its not responding.
Is there any way to get this drive to working order? I know that my friend has a pc with win10 pro, should i go and try to open it from there using bitlocker?
 

hang-the-9

Titan
Moderator
If the USB drive won't format, no you can't fix it, it is pretty much guaranteed to be an issue with the storage chips. Bitlocker won't prevent you from formatting the disk, just from reading the contents. Try using the diskpart utility to wipe all the partitions off it, then try to create a new partition and format that.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS