USB wifi adapters not recognized


Sep 24, 2011
hi, i just built a new rig (first build) and when i try to plug in my wifi usb adapter it says "the device is not recognized" and then says that it can't install the drivers or something to that extent. i've manually installed the correct drivers but when i go to device manager it still has an exclamation mark and says that the device has a problem. i've tried the adapter on another computer and it works fine, i've also got a 2nd adapter i tried to run on my new build and the exact same thing happens. i've shut off legacy usb in the mobo because i read that might help, i also disabled all power saving on the usb ports. is there a step i might have missed while installing the motherboard? a cable i might have missed or something? the internet works fine when i plug in an ethernet cable so i'm not really sure. i've tried removing and re installing drivers and it still won't work. the wifi adapter was working fine on my old setup, but i took the hard drives from my old computer and installed them in the new rig but everything else is new. my setup is
i2500k cpu
asrock p67 mobo
8gb ripjaws ram
earthwatts 650 psu
his 6950 video card

anyone have any ideas because this is driving me crazy. should i reformat windows? thanks