Question USB2-Ports not working right. Drives are not recognized

Mar 25, 2023
hey guys,

i have a realy weird problem with my usb-ports on the mainboard.

My mainboard is the GA-AB350M-DS3H from Gygabite.

The strange thing is, that no USB 2.0 port is working in the way it should.

I can plug my mouse and my keyboard in them and things are working fine. But if i am plugging an usb-drive it will show me an error, that the device can not be detected.

My Motherboard has two AMD USB 3.10 extensible-Hostcontrollers and two USB-ROOT-Hubs(USB3.0) and one generic hub. I am not an expert, so i do not know if this is weird or not. I will put a picture of my usb-controller in this post.

I downloaded AIDA Extreme 64 and the programm showed me that, one AMD USB Hostcontroller, is responsible for the USB3-ports on the back of my pc. These ports are working fine. They recognize USB3- and USB2-Drives correctly. So no problem there.

The other Hostcontroller is responsible for my four USB2-ports on the mainboard, but also for two USB2-ports and two USB3-ports on the case.
The USB3-ports on the case are recognising USB3-drives but no USB2-drives.

So to put it in one sentence. USB2-ports are having energy (mouse and keyboard are working), but can not detect drives. And even the two USB3 ports on the case can not detect USB2-drives but USB3-drives.

The really strange thing is, that even in the BIOS, the USB2.0 ports are not recognizing drives i plug in. I also tried to use Ubuntu and there was the same problem. Nothing recognized. So i do not think that it is a Windows-problem.

Things i have done: Updating my BIOS to the newest Version. Nothing changed. I also replaced the battery of my mainboard, with waiting some minutes. Nothing. I cleared the CMOS Jumper. Nothing.
The error that the device-manager is showing me, is something many people get "UNKOWN USB Device (Set adress failed)". The solutions that are recommended are changing the energy-options. Disabling them etc.. I tried these things, too. But still no change. And i do not think it will be something like this, because even BIOS is not recognizing them. I also tried using a programm calles usboblivion. But still having the same problem.

Do you have an idea what the problem can be or how i can fix this?

Sorry for my english. Hope everything is understandable.

Picture of my usb-controller: View: